install qubes-core-agent makes HVM not boot


Apart from the normal Qubes usages of the different templates, I am also using a Debian 10 HVM which is LVM and Encrypted.
As sometimes I need to copy-paste data from and to it, I tried to figure out how I could use parts from the Debian templates in this HVM so I could just use the menu when right clicking on a file and selecting Copy or Move to another VM.
Luckily I made a clone from my HVM first before tampering with it. But I’ve also tried below steps with a fresh Debian 10.6.0 install. I’ve also tried different setups like normal, LVM and LVM+encrypted, but they all gave the same issue.

Steps I followed:

  • Copied the /etc/apt/qubes-r4.list from the Qubes Debian template to the HVM.
  • Added Qubes signing keys to the HVM.
  • Terminal ‘sudo apt install qubes-core-agent’ installed a bunch of things (see below pastebin).
    (and I also tried ‘sudo apt install qubes-vm-recommended’ with the same result)
  • Reboot.

During reboot it gives error:
[FAILED] Failed to start djust root filesystem size.
Then a few green [OK] lines
but then hangs a while on
[*** ] A start job is running for /dev/xvdc1
and when it can’t start that, it jumps to ‘tty1’

I have even tried above with a fresh Fedora 32 install with qubes-r4.repo from the Fedora template.
And for the sake of testing, I’ve even tried with a fresh Ubuntu and Unman’s repo and keys from but both to no avail.

I’ve copied the install log from Debian Terminal to pastebin:

And in there I can see some errors, but I don’t know enough from Linux to know how to solve those issues.

I must be doing something structuraly wrong as it fails on 3 different distro’s. But apparently I can’t see the wood for the trees anymore and would appreciate some help or directions.

Thank you in advance

I personally use Templates HVMs. I could not get qubes-core-agent to work consistently. You can transfer files between an HVM (non Qubes and not a template) and a Qubes VM just by switching templates if you use only the home directory.

Strange because I have (longstanding) standaloneVMs
with Qubes tools installed which work fine.
I cant see that pastebin, so I’m not clear what your issue is.
I’ll try from fresh and see if I can diagnose the problem.

The template switch hack is clever, but must be a pain to work. In the
absence of anything else it would do.
An alternative approach would be to attach disks at startup and use
those to transfer files between qubes - you could use a physical disk
(USB) or a disk image, either works fine.

More of a comment not help.

Switching templates is not a pain 4 me. I can tell you also Zulu mount when switching is a blessing too. You have different file systems, passwords etc…

I don’t know about the others but I’m hacked on a regular basis in Qubes with 100% HCL. Sometimes more than once a day.

Here is a secret that I guard. Firewalld works in these templates and also good traffic analysis.

Good luck and it is a strength not a weakness!