Install of Qubes 4.2 RC5 issue...SOLVED

Alright guys,

Ready to upgrade to (Qubes 4.2 RC5). I had to make some changes in my BIOS as I can chose either (legacy or UEFI). Built user installer, had a issue with my MOBO as I have a intergrated LSI3008, which doesn’t work right. So I have a PCI raid controller install and working Great with all version of Qubes OS (4.0-4.1.2) and I was using (legacy MBR). I had to disable the onboard LSI controller since going to use Qubes UEFI as it was over riding my PCI raid card for UEFI. Plus made all needed other changes for UEFI to work and BLAM, UEFI on my PCI card came to life!!!

Started USB installation (Qubes 4.2 RC5). Went very smooth, UEFI USB installer launch did my setup, was able to select all my GPT SSD’s I wanted to use, setup accounts, installation started with out a issue, went great.

Rebooted took out USB and NOTHING…

Qubes will not boot…

So, here is what i see…

-Accesing BIOS/SETUP…Yes i can
-UEFI still enabled…Yes
-Secure Boot off…Yes
-In boot options “Qubes” is seen and UEFI is still selected…

Any help or ideas would be great.
I have “decommed” Qubes 4.1.2 as we will be going to 4.2 soon, so i am in limbo for now…

Thank you all for your help…

What happens, if you

  1. re-insert the USB stick
  2. from the BIOS, select the USB as boot medium
  3. press esc at the USB boot menu
  4. type configfile ( and hit TAB


If you see something like:

Possible devices are:
hd0 hd1

then you can try with configfile (hd0 and hit TAB. If you get a single possible partition, then re-try with configfile (hd1. You are looking for a partition that looks like:

Partition hdX,gptY: Filesystem type fat

If you have a partition like that, try:

configfile (hdX,gptY)/efi/qubes/grub.cfg

Does that give you a boot-menu?


Do you get into GRUB menu?

1 Like

Ok guys,

I am still get a black screen once i boot so all last night i was trying to figiure out “WTH” is going on. I then decided to run my (on board diagnostics) thinking gpx,memory problem. Well 2 hrs later i have 2 SSD’s that have failed. THe error code was (ERROR: Failed EFI), everything else is working and passed.
I am now in the process of taking down my server and replacing SSD’s. Also i see now 4.2 has gone " left testing" so i will “dl” the latest and greatest and run with that. “IF” I still have the same problem after installing new SSD’s I will report back.

THank you both for your time and effort.

Thank you ChrisA but I was able to get Qubes 4.2 finally installed and explain what i had to do. But I have a nother issue seen here if you could assist…

i will make this as solved now…