Can not install 4.2

Alrigt guys,

So i recieved my new SSD’s, did my due dilligence (erase,set to GPT,format FAT32). Installed them to my hardware RAID controller, controller see thems, BIOS set to UEFI. USB Qubes installer launches no problem, go through the process to start install BUT when i go to select my SSD’s, they are not there to select. Field is BLANK, like they don’t exist. Down on the bottom of them page it states “No disk found, attach drives”. I hit “rescan” maybe i have to and again after clicking “rescan” no drives appear.

Well, this is a problem, I then do the following and have been BANGING my head for the pass 3 days now…

  • Reflashed BIOS
  • MOVED the hardware RAID controller to different PCIe slots
  • Rebuilt USB installer for 4.2 (GPT)
  • Confirmed BIOS settings EUFI AND SUCH
  • Went into my RAID controller at “boot” AND it see’s all my SSD’s,sizes, non-raid setup, i have even set which disk to boot from which is -00-00.

Still get the same results when trying to install Qubes 4.2 from USB when going to select drives…

None are found to select…

So for the hell of it i took another lInux USB installer to my Qubes computer and what do you know. it saw all the SSD’s and was ready to install BUT i stopped it.

Am i missing something here?
Any help would be GREAT, I love my qube!!!

Which distribution?
Try Fedora 37 installer.
Maybe the RAID controller driver is missing and you need to load it in the installer manually.

I used the last option which was" 4.2 latest linux 6.x.x with fedora 37". No the only thing that has changed was that we afrer forced now to use UEFI, as this Raid card was working just fine from Qubes 4.0-4.1.2 with all the same hardware & MBR. The linux USB i used was kodachi 8.27 which use UEFI only. Once you boot the USB that is the only option it comes with and i could have installed it if i wanted to.

So i am lost now what to do

it’s weird cuz when i have my Qubes 4.2 USB installer up and working “as if i am getting ready to install”. When i am in the area where to select which SSD’s to use for installing to. The only thing that will show up is the USB (sometimes it appears/sometimes it doesn’t, strange)and no other SSD’s. if I hit “rescan” for drives, all of the sudden the USB is now gone and it never comes back, even after multip rescans, as I am trying to get SSD’s to populate…NOTHING comes up

Raid controller is working as i have stated i can login to it at “boot”(ctrl+R) and it see’s all my drives, drive properties, raid config setups, which i am using non-raid array… I even tested setting up a raid array with 4 SSD’s and it applied, though i deleted it after “just checking to see if all is working with this card, and apperantly it is”.

BIOS i have checked again…UEFI,ACHI,SECURE BOOT “OFF”, am I missing anything else? AND when I am in BIOS under my UEFI tab, my system see the USB “UEFI Qubes, name of USB vendor”…

i have tried all 2.0 USB’s on my server with mu Qubes USB installer and they work “Qubes installer comes up and launches just great”…

All SSD’S set to GPT, formatted FAT32… all fully erased as well as fully formatted. No quick fix here, even though it took many and i mean many hours to do these…

The only things i can come up with are…
1.) Try a different USB to build my installer (as this is a 3.1 ThunderBolt USB)
2.) Maybe something is wrong with the RAID card and UEFI ( work fine Qubes 4.0-4.1.2 MBR)
IF I have to find the UEFI driver for this card “well, good luck with that for me” then having to reinstall it under FreeDOS, IF I can as there isn’t much in the way of doing that. It’s as if vendors are not to open on how to do that BUT hell if you use “Windows” just download and click the installer and it will do the rest, us linux users not so much help there.

Can you check if the RAID will be detected in Qubes OS 4.1.2 installer in UEFI mode?

Well well well…I have found my"problem" after testing and reviewing everything. Upon researching and emailing with people I have a few paths to addressed this issue.This was a well known problem with this computer. The OEM really didn’t addressed this and many services tickets were opened with the OEM, it came right after a certain BIOS UPDATE and UEFI. All of these people were kind enought to send me links to forums,papers,videos as well as “tool sets/frimware” to fix my problem. They had me go into areas to do cmd’s to look for a certain error/issue with UEFI. YUP, I have it.

Path #1…pcie LSI 3008 raid card
Path #2…onboard LSI SAS 3008 controller

Both “paths” can be done, it just takes a little time and effort. While I have heard (pro’s & con’s) from both sides of the bench and each one has both advantages & disadvantages, I now have a choice to make and how i want to do this. it has been a VERY long week for me and BANGING my head. So this weekend i HOPE I can wrap this up and get back online with my “Qube”

1 Like

i now need someones HELP!!!

Here is where I am at now…

So my “onboard raid card” has some serious issues, i couldn’t even get it too full flash. sas3flash kept kicking back “firmware” errors invaild check sum. Well this these roms/firmware was directly from the OME’s site, even dl it twice and tried to many times to flash and failed. Just couldn’t get it to work.

So i went now with option 2 “pcie” raid card. Did everything that was explained to me by everyone who was helping me, took a bit as i had many things to flash and do, not only from the firmware/rom flash side but also hardware “jump headers”.

Well it worked!!! MBR rom flashed, UEFI rom flashed, IT mode flashed, applied raid card address. Rebooted and followed instruction people gave me and Raid card came back online after reboot system seen it AND
all SSD’S showed up with address’s,size, everything and everything enabled…MBR,UEFI,IT mode

put in my Qubes 4.2 USB installer,booted to it and during “post” of USB installed it now sees all my SSD’s and assigned them names…sda,sdb,sdc…ect

GUI comes up did all my setup go to select SSD’s and SHI**** they are all there,WOW!!!

Qubes installs just fine… Question here (after install, do i remove my USB when i reboot, because i do?)

Now hopefully someone can help…

After install i reboot BUT I remove my USB installer and upon rebooting i get “NO boot device found” hit F1 to try again.

So I go into UEFI F12 menu well Qubes is there
So I go into BIOS F2 in “boot devices” Qubes is there listed under UEFI boot menu
So I go into PCIE raid utility CTRL C and make sure that the “ONLY SSD” I installed Qubes 4.2 is seen, and it is AND I only installed to 1 SSD, I have ot selected as “BOOT”, I see raid card has assigned a address,list size all of that information for the SSD, it’s on the top of the SSD order, stated as BOOT

Again i reboot and same thing “No boot device found” even though i see Qubes is installed…

Some help PLEASE guys…

Side note:
Well it is now oblivious that I had a UEFI problem AND this “onboard sas” is srewed. i have it disabled in BIOS…both ports and controller

As I was told in IT Mode that RAID is not available BUT I have more options as well as formats now to work with, Ok I can see the power here…

You can try to use EFI fallback path:

i will lok at those BUT I believe I fond my issue…

You see when I launch my Raid card config page “CTRL C”. The main page list the default config for my raid card. The last column has a column called “Boot device” and it states “Boot Device” is Slot 0, I can not change this even though i can tab over to the column. Well my SSD that I selected as “Boot Device” is Slot 5. it appears that even though i have it selected as my “Boot Device” and at the top of my list i can’t boot because my Raid card states “Boot Device” is Slot 0.

So now i have to figure out which “cable” coming off my Raid card represents “Sloth 0”, then I will put a piece of Electrical tape on it to flag it for me to use as the “Boot device”. Which i will reset my Raid card and start all over, which i am in the process now pulled out SSD’s, erase,format and reinstall.

Next question:

I lost the ability to do “Raid” setups on my card after flashing, which was explained to me and the advantages of doing this. Now I did see when I did my install, while i can “select” SSD’s to install to i saw that i could also “choose” which SSD “Boot config” can be installed to IF I select many SSD’s.
Does this me than… That I can span “Qubes” across many drives while only keeping one as a “Boot device” even though i don’t have these SSD’s in a Raid configuration and Qubes will still boot?

I will look into what you have giving me IF my option of “trying to find” which cable represetns “Slot 0” and use that…

THank you for your time

THank you guys for all the help. I was able to address my “booting” issue, my Qube is booting and loaded. I did have 1 other issue but I was able to also address that.Now just in the process of doing a basic setup updating.

1 Like