IBus settings not persistent

I’m trying to get Chinese input to work in a standalone Qube. I ran the following to install it:
sudo apt install ibus ibus-pinyin

Then I ran ibus-setup to add the input method and configure it.

The general IBus settings (disabling systray icon, adding the new input method) are persistent across reboots, but the input-specific settings (e.g. fuzzy pinyin) are reset to their default values on reboot. From my understanding of the source code, the settings should be stored as dconf values, but they don’t appear there when changing the configuration.

Any idea how to fix this?

I just replaced it with ibus-libpinyin. That seems to be working fine.

1 Like

Hi norbertog,
can you do a howto please, I’m having the same problems, the setup is not persiting after reboot.
thank you

Sorry for the late replay, I didn’t check here in a while. I didn’t do anything special, I just did apt install ibus-libpinyin. What exactly is not persistent for you? Did you install it in the appvm instead of the templatevm?

thank you already resolved