I7-8700 - Qubes Installation states missing IOMMU/VT-d/AMD-Vi


I’m having issues installing Qubes due to my CPU apparently not supporting IOMMU despite the following sources saying it does.


Intel Virtualization Technology is also enabled in the BIOS too, so I’m not sure what I’m missing at this point.Any help will be greatly appreciated.

i guess that because tiger lake cpu

What do you mean by “tiger lake”?

11-gen intel cpu

So you need an 11th gen intel CPU to utilize VT-d tech?

no, 11th gen intel CPU don’t work well with qubes

Ahh my apologies I referenced the wrong link. My CPU is i7-8700 not the i7-1195G7.

then idk what is this problem

would it have anything to do with my motherboard not being compliant with VT-d or something?

no, try to skip it

Ill have another go at it later today and let you know how it goes, might make up a new usb media installation or something

I assume you mean the i7-8700K. Have you checked if your BIOS/UEFI has an option for “Vt-d” or “Vt-x” in addition to “virtualization”?

Do you feel comfortable disclosing which computer model you are using?

1 Like

Yeah I can disclose that no worries. Anything to try and resolve this issue. By computer model your referring to the motherboard model right?

By computer model your referring to the motherboard model right?

You don’t even need to tell me. Here is what I would do with the information:

  1. Check if it’s contained in the HCL
  2. If so, click on the name of the reporter to go to the thread
  3. Check if the thread mentions anything like your issue
  4. If so, point you to it or recommend to reply there and ask for help

Other possibilities:

  • check which BIOS you are using and search the HCL for that
  • check your CPU (there is only one match in the HCL) and try to talk to that reporter
  • maybe there a logs one can check even in the installer case, but I don’t know how
1 Like

Ahh that’s great help thanks! I’ll check my motherboard against that list and update this post later whether it was successful or not

  • Have you enabled virtualization in bios / uefi ?
  • Are you trying to install qubes via vmware / vbox ?

So checking the HCL I can’t find an exact match under the motherboards section. I’ve got an MSI Z370 motherboard.

I also created a new installation media as I was using one I made a month ago thinking maybe that was the issue but also no luck :frowning:

I can also confirm that Intel Virtualization Technology is definitely turned on in the BIOS.

Does your BIOS support legacy boot?

Not only the CPU has to support VT-d, but also key motherboard components (NB/SB)

< http://maikejansen.de/vt-d-motherboard.html >

Intel VT-D Tech [Disabled]

< MSI Z370 GAMING PLUS Manual (Page 59 of 108) | ManualsLib >

My motherboard is the MSI Z370 … got the i7 8700k … stuck on turning IOMMU on … since I only have one IOMMU group. … I updated the bios to the latest version, … everything is now in it’s own iommu groups.

< https://www.reddit.com/r/VFIO/comments/oej3v0/only_one_iommu_group/ >

Bottom-line: a 10 minute web search results in several folks trying to run KVM or XEN on Z370 boards with your exact CPU and having black screens. There is some indication that a BIOS upgrade might resolve that situation. If you are thinking about getting another motherboard … make sure it has positive reports in the HCL.

A BIOS upgrade sounds like the next logical step, otherwise I’ll start searching for a suitable motherboard replacement.

1 Like