I try installing on my laptop, but can't get past the first text screen

Hi everyone. I tried installing my Qubes OS, but when I disable the Secure boot and boot from my USB drive, it shows a display of text only to cut abruptly to a black screen I can’t seem to escape out of outside of rebooting the computer. I originally was going to post that I had this same problem that another user was having, but it’s on a section of the forums that posts threads by google users and won’t let me reply there. As a result I have to make my own topic here. I’ve noticed on the website that partitioning the ISO at less than 8 GB could work, but I tried and it sadly didn’t. What should I do?

Give some more detail.

What is the laptop?
What have you read so far (obviously you have searched and found the
mailing lists - mirrored at qubes-users)?
What have you tried?

I never presume to speak for the Qubes team.
When I comment in the Forum or in the mailing lists I speak for myself.
1 Like

I have a Dell G5 laptop. I’ve made an attempt at partitioning a USB at 4 GB instead of 8 and updated the Bios as well, but the result is the same.

1 Like

If it’s the USB drive, is there a way to install without a USB? Could it be an issue with my monitor?(read somewhere about a possibility that some laptop monitors could have problems interacting with the installation USB)

  1. How you create installation medium ?
  2. Dell G5 5590 I7-9750H and RTX 2060 is this your spec?
  3. Are you boot with bios / uefi ?
  4. Is there any option to use discrete only instead of using intel gpu + discrete card (hybrid mode)?
  5. What qubes os version you try to install ?

1.I installed the ISO on the USB using Rufus 3.17.1846

2.The specs are here(they seem to be a bit different than including RTX since my graphics card is an Nvidia Geforce GTX 1050)

3.I booted with Uefi rather than legacy. Will legacy mode work?

4.What do you refer to as discrete? Is it an option in the bios that allows my monitor to better read the USB.

5.The version i’m trying to install is R4.0.4

Thanks for all these replies. It really helps.

Try legacy first, In my case my laptop won’t pass installation screen if using UEFI + hybrid mode (which is use igpu), and i need to change to discrete only for installation then hybrid mode after install. If using legacy bios, hybrid mode is okay out of the box.

I think there’s nothing to do with your monitor since the problem is in gpu.

If legacy still not work, try using 8/16gb flashdrive.

Alright. I’ve managed to god through with the installation. However after it installs i’m a bit lost on where to go in the bios to boot it. I installed it on an extra hard drive in my Computer, but while the OS is there on the secondary harddrive I don’t know how to reach it.

simply change the order of boot would do, in my laptop it’s fn+f12, or direct change permanently at your settings by pressing fn+f2 or delete.

Tried it. The drive I installed it on doesn’t show up. The secondary hard driver won’t even show in My Computer. It used to before I installed. Is there a way for my computer to recognize it?

ok so your drive is not shown up in boot menu, it means you boot with uefi, since your drive is bios, it will not recognized by boot menu or you boot in bios but your hdd is uefi, got what i mean ?

The thing is, when I go to the bios configuration it doesn’t show on the boot order manager. Do I have to assign it a drive letter? The hard drive for my OS is Drive C. The drive I have it installed on is a WDC WDS500G2BOB(That’s what the driver properties says). My Windows drive is a Toshiba MQ04ABF100.

could you go to bios settings, and take a pict in your storage menu.

1 Like

It seems that the only thing I can boot in Legacy mode is Onboard NIC. When I boot from there I get a message that says “PXE-E61:Media test failure, check cable.” This gives me the indication that Onboard NIC obviously isn’t related to any harddrive.

As for what is available in the bios, in legacy external devices I seem to get only the options, Diskette drive, USB storage device, CD/DVD/CD-RW Drive, and Onboard NIC. At first I thought something was wrong with the hard drive I installed it one, but since it’s listed as Legacy External Devices I guess that’s to be expected(external being the key word here).

However, as far as the internal hard drives go, the reason why I bring up Legacy External Devices is that it doesn’t apply to the secondary hard drive I have in my computer. I tried UEFI boot options to add the hard drive, but when I click add it shows 4 options of Sata drives that seem to named the same save for the hard drive numbers. It’s a bit confusing. I originally took a picture of this with my phone for convenience, but I did zoom in to make it a bit clearer.

that uuid, but i need to know that is uuid of what drive
(not sure will this work)
boot the usb with uefi then switch to tty2 (Ctrl+Alt+F2)
run lsblk

Sorry for the late reply. I tried to, but as i’ve mentioned I can’t boot into the USB in Uefi. Only legacy. I tried disabling Secure boot and PTT, but it still won’t boot unless it’s in Legacy.

try legacy
however uuid only available in gpt which only available in uefi, so i not sure this will work at all (the later part, not this)

I’m a bit confused. I got an instruction to type in wmic path win32_computersystemproduct get uuid in the command line console. The UUID is 4C4C4544-0032-3110-8035-B5C04F4E3432

Is this what you are referring to?

oh, windows stuff? this is not windows, not even fully linux either. that your laptop uuid, not partitions uuid

Universally unique identifier (UUID) for this product. A UUID is a 128-bit identifier that is guaranteed to be different from other generated UUIDs. If a UUID is not available, a UUID of all zeros is used.

it don’t match any uuid in the picture