Qube OS Installation Black Screen

Hi There Iam Trying To install Qube OS On my laptop
Its Dell G5 5590 I7-9750H and RTX 2060 I flash the iso of Qube on flash 8 Gb and i have external 1tb adata First of course i disable secure boot and change boot to legacy and boot from USB that have The image of Qube Then I install It On the External Hard Drive Everything Works fine Until i Reboot Qube than configure It you know Configure the whonix and fedora and Debian and Then at Setting the Networking after That a Black Screen apear And I tried to install it again From Zero But i stuck at the same point So ? Does My laptop doesn’t support Qube???

Most of the reports I have seen are usually due to sys-usb. Can you try install without sys-usb first. If it succeed create sys-usb if supported by your device.
Btw it may be another issue as there is a open issue about it on Github.

1 Like

Thanks Bro Your A Hero It’s installed But I have No network access No wifi ? What should i do please help me

First of all check that you have templates installed and your mouse and keyboard can work properly.
Do you have sys-net and sys-firewall installed already? or you skipped their installation too. If you have skipped that then you have to create them for networking. I cannot find a documentation for sys-net creation so I am giving some instructions-
Create a VM “sys-net” with Fedora-32 template with no networking and which can provide network.
Then find out PCI device for your networking and attach it to sys-net.
Report back if you can do that.
And don’t attach any usb device to your laptop for time being until unless you are ready with knowledge.
Maybe @adw or @deeplow can link some documentation for DIY docs for sys-net etc. creation.

1 Like

first thank you bro Secondly Sys-net and sys-firewall is installed But i have two wifi that built( intel ac 9560) and ALFA That Have (Ralink RT3070) and none of them are detected however when i run
Lsusb i can see the ALFA but when i run lspci -k I can’t see the (intel AC 9560) the keyboard and mouse are working…

State Update :- I can’t Find My WiFi PCI Card (Built-in Wifi Are Not Regonized) So I try To use my adapter USB i add USB to qube by qubesctl top enable and Reboot it it get crushed So ? What should i do? Any help ?


Nowadays, I suppose the recommended way to do it is with salt, but it’s kind of hard to understand (for me, anyway):

1 Like

Any help sir or it’s my pc don’t Requirements with Qube

Actually there is easy documentation for sys-net, sys-firewall etc. creation but those are for disposable. (I myself use this)

I think your PC is compatible as you were able to install without sys-usb.

You need to read documentation if it’s your first ever attempt with Qubes. Read PCI devices, USB qubes, Device handling, Management stack etc. from documentation.
After that find out bdf etc of yor devices. See if your devices are attached to sys-net with help of qubes settings of sys-net.
It will take some time to understand, keep patience… :slightly_smiling_face:

1 Like