I can only install Qubes OS without IOMMU but then it doesn't work correctly

I was trying to install Qubes OS from my USB drive to SSD but during the installation it stopped at [OK] Reached target basic system. Following some advice on the internet, I went to the BIOS and checked if CPU virtualization and IOMMU were enabled, and they were.
I tried to disable IOMMU and it worked, since I could end the installation process (even if it gave me a warning about not having “IOMMU/VT-d/AMD-Vi”.
But, of course, the chickens came home to roost. When I try to start a qube it says that it cannot do it because of not having IOMMU/VT-d/AMD-Vi.
I have even tried to re-enable IOMMU when the system was already installed, but then I couldn’t access because the OS loading was stuck on the screen with the Qube logo.
What can I do?
Installing Qubes OS with IOMMU doesn’t work, it only installs without it.
But then it doesn’t work correctly. And if I try to re-enable IOMMU after, it’s even worse.

You can try to search the forum for tips on how to fix it if you search for your hardware here (CPU, GPU, motherboard).

What CPU/mainboard do you have?

  • Motherboard: ASUS TUF GAMING B550-PLUS
  • CPU: AMD Ryzen 5 3600

Idk, I have searched for my motherboard and for my cpu on that list (separately) and honestly it looks like the two components are fine.

Can you try Qubes OS 4.2-RC5 ? It’s the incoming new version with a greater hardware compatibility.

Or you can try Qubes OS 4.1.2 with kernel-latest installer menu entry.

You can also try to add x2apic=false to the Xen command line in grub:

1 Like

Qubes 4.2 will be released soon. It may be a better idea to try to install the rc5 version with a newer kernel-latest package than the one provided in 4.1.2, which will need to be upgraded soon anyway.