Huge problems with Qubes installation on the strongest PC. Currently, I checked everything what Reddit suggested, but problems still the same. Give me some recommendation, what I can do/check more

Hello. I have massive problems with Qubes 4.1.1, because I can’t install it on my main PC. Reddit tried to solve problems, but with no success at the moment. I’m not sure, where is the problem and how I can fix it.

I tried to install Qubes on two different strong PC. Important to remember is that, on my PC, Qubes not work, but on PC my brother, Qubes work very well.

My PC components:
CPU: AMD Ryzen 9 5950X 16-Core Processor.
GPU: AMD Radeon RX 6600 XT.
Memory: 65536 MB (2x 32768) Kingston FURY 3600 MHz.
BIOS Ver: 4204.
OS Build Date: 03/07/2022.

My brother PC:
CPU: AMD RYZEN 5 3600 6-Core Processor.
Memory: 32768 MB (4x 8192).
BIOS Ver: E7C02AMS.360.
BIOS Build Date: 04/22/2020.

I spent a lot of time to solve the problems, but with no success. With CTM on, Qubes freeze on loading bar, at the beginning. You can check it on that film: Qubes Installation Error - YouTube at 1:20. The last bar all time are highlighted. That operation was while I had my M.2 disk, so when I removed it, I got another error: Warning: /dev/root does not exist. Generating "/run/initramfs/rdsosreport.txt" Entering emergency mode. Exit the shell to continue.. Theoretically I could press Control+D or Enter, but probably some freeze appeared and not matter what I pressed, system not worked.

With CTM off, my USB stick was visible as UEFI usb-stick-name. I got other error: [FAILED] failed to start udev Wait for Complete Device Initialization. After that appear few more information with green [OK], but [OK] reached target Basic System always was the last information, nothing appear more. In total, 11x OK and 1x FAILED.

I swapped GPU my brother to my PC, but I got the same errors as on my GPU. Next, I switched RAM my brother to my PC, and again the same errors exist. In that way, I exclude problem with RX 6600 XT and Kingston FURY 3600 MHz (DDR4).

About HCL, theoretically everything should be fine with MB and CPU, because I found my CPU (on HCL, CPU end with letter “x” (5950x), instead of “X” (5950X). Furthermore, not started with number 9 (Ryzen 5950x) instead of (Ryzen 9 5950X) but I think it’s just a mistake. The full name of hardware is: Asus ProArt B550-Creator Ryzen 5950x AMD Radeon RX570.

Next, if we check MB, on HCL exist Asus TUF GAMING X570-PLUS Ryzen 5 3600 AMD Radeon RX570. My MB is the same, but with Wi-Fi, so I have TUF GAMING X570-PLUS (Wi-Fi). The one thing, what that MB added more is: ASUS Wi-Fi module (Wi-Fi 802.11 a/b/g/n/ac and Bluetooth v5.0).

What can I write more, M.2 disks are almost the same (my is Samsung 980 Pro, my brother have Samsung 970 Pro). His BIOS work on Gigabyte motherboard, my on ASUS, so probably settings are different, but he has all time AHCI on and CTM on. Except that, I tested different software programs to boot (Rufus, Fedora Media Writer) and recommended option and DD option. I tested different USB-sticks, into different USB inputs, errors all time the same. I tested too Qubes 4.0.4 and 4.1.1, and iso from this: but all time, errors on 4.1.1 are the same, on 4.0.4 other, but it’s old, unsupported version. Just I tested out of curiosity.

Theoretically, I can update my BIOS to the newest version, because something was change:

  1. Update AMD AM4 AGESA V2 PI
  2. Fix AMD fTPM issue causes random stuttering.

I can do it tomorrow, because I need to buy USB-stick. I can’t use the ones I have. But it really could change something? My brother BIOS is from 2020, and Qubes works perfect. But as I said, maybe he has something on/off on BIOS what I don’t have, and that’s block me. At the end, I want to add something more about my RAM settings in BIOS. I’m not sure know what was that, but it was related to downgrade RAM MHz to CPU MHz, or the other way. I did it, because CPU from AMD works much better, if CPU have similar MHz to RAM, or the other way (RAM works better). I’m not sure how it works, but I read that when I built my PC. In BIOS in that way, I have chosen some profile for that, and that’s it. It makes sense, what I wrote?

Oh, and I will add something more. My brother have only Windows 10 installed, but when I installed it on my PC instead of Fedora 36 (my main OS), nothing change too, errors still the same.

Discussion on Reddit is still active. I wrote here everything what on Reddit + additional info here. If you still want to check Reddit, feel free, topic names is: “Qubes 4.1.1 impossible to install on the strongest PC. I tried everything what I can, always some errors exist. Precise description inside.”

Well, sorry for any language mistakes. English is not my main language, so please remember that. If you have an idea what can I do/check more, please tell me. I stuck right now, and I don’t know what’s going on. My components are too young (they don’t have enough support yet) or the other way, something is too old? I built my PC around 2 months ago, every Linux works fantastic and every day I work with virtualization, I don’t have any problems with QEMU/KVM and VirtualBox.


[FAILED] failed to start udev Wait for Complete Device Initialization

Maybe your issue is related.

Which BIOS version are you currently running? Based on this post (Unable to install 4.1.0 - udev error while assigning device slot ID) and now my experience there is an issue with AMD AM4 AGESA V2 PI onwards including latest AMD AM4 AGESA V2 PI