How to modify the Qubes-R4.0.4-x86_64.iso

Hello Qubes users,

I was wondering if someone can help me with the issues I am having while installing Qubes on my new build. Thanks in advance.

System:

CPU: i5 10500

MOB: ASROCK ITX H410

RAM: 16 gb

DRIVE: NVME WD BLACK

Issue:

After downloading and verifying the ISO, I burned it on to a USB (Kingston 8GB). I tried with etcher and also via dd:

sudo dd if=Qubes-RX-x86_64.iso of=/dev/sdY status=progress bs=1048576 && sync

Both ways I get to the same error, Xen is relinquishing VGA console and a black screen.

I started troubleshooting and the first step will be to modify the BOOTX64.cfg , removing noexitboot and mapbs. As indicated in UEFI Troubleshooting | Qubes OS

Here is where my issue starts, I am not able to modify the ISO or the burned USB, so I decided to edit the ISO image by copying the content locally and repacking it.

I am following the following steps:

1 Create a directory where I can copy the content and mount Qubes ISO

mkdir /tmp/my_iso

cd /tmp/my_iso/

mount -t iso9660 -o loop ~/Qubes-R4.0.4-x86_64.iso /mnt/

cd /mnt

2 Copy the content of the ISO on the directory

tar cf - . | (cd /tmp/my_iso; tar xfp -)

3 Modify the ISO

cd /tmp/my_iso

nano /tmp/my_iso/EFI/BOOT/BOOTX64.cfg

4 Repack the ISO

cd /tmp/my_iso

mkisofs -o Qubes-R4.0.4-x86_64.iso -b isolinux.bin -c boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -J -R -V "Qubes-R4.0.4-x86_64" .

5 Make it Bootable

isohybrid Qubes-R4.0.4-x86_64.iso

I then take that ISO and burn it to the USB. The problem is my BIOS will not recognize it as bootable.

I was wondering if anyone else is having the same issue or could guide me on how to edit the BOOTX64.cfg file on the ISO directly.

Thanks in advance

Welcome @cyberest!

I also had this error, and could never find a tutorial that actually explained how to edit a write-only iso and still keep it recognizable as a bootable device (I also mounted, edited, and mkisofs, but Coreboot wouldn’t see it as bootable).

I had an apci error (IIRC) which had to do with my CPU generation, and Reddit told me that my hardware needed a kernel >= 5.8. Since the signed Qubes R4.0 didn’t have kernel >= 5.8, I ended up coming here to ask if R4.1 supported a kernel >= 5.8.

I tried one of the signed R4.1 builds, but that didn’t work, so I ended up downloading several R4.1 iso files from the Qubes OpenQA and trying them. One of them worked, and that’s what I’m using to type this right now. It’s not signed by a dev, so that’s risky, but so is Windows ¯\_(ツ)_/¯.

Search on github or here for the signed R4.1 builds, and try those. If they don’t work, consider the OpenQA.

1 Like
2 Likes

Thanks @qubes-kernel-5.8. I will try the R4.1 iso

1 Like