Error in CPU 0 in Qubes 4.1 Beta

I hope you are all having a good day!


Intel Core i7-1165G7
Intel Iris Xe Graphics

When installing Qubes 4.0.4, the screen does not show anything (black screen). As a user pointed out, this might be due to Qubes 4.0.4 not supporting kernels <= 5.8. I did not have this problem with Qubes R4.1.0 Beta, and I successfully got a screen where I could select to either test the medium and then install later or install now. Sadly, both crash with an error in CPU 0.

In my previous post, I got the advice to change BOOTX64.cfg and remove noexitboot and mapbs. Sadly, this resulted in an unbootable file for me and changing the file was difficult as it’s read only. (For anyone stumbling upon this later, I tried the steps listed here: How to modify the Qubes-R4.0.4-x86_64.iso) If anyone has an easier way to change these options, I’d be happy to know as the method listed on the wiki did not work for me.

My problem is that version 4.1 does not seem to have a BOOTX64.cfg file, but instead a BOOTX64.EFI file. I’m not sure how I could modify this file, or if I am supposed to. What would be the best way for me to proceed? All advice is welcome! :slight_smile:

\ case 1

  1. Are you sure that you are using BOOTX64.efi ? if you missing BOOTX64.cfg you must’ve seen xen load version ......... no configuration loaded something like that, did you see that ?

\ case 2

  1. Can you provide efibootmgr -v in the system ? you can use qubes os rescue, enter your disk pass and run the command.

Hello 51lieal, thanks for the reply!

Case 1:
When I inspect the filesystem of Qubes 4.1, specifically the /EFI/BOOT folder, I see this:

I tried adding the BOOTX64.cfg file from Qubes 4.0.4 into Qubes 4.1, but there doesn’t seem to be enough space.

Case 2:
I tried booting the USB and entering Qubes OS rescue in command line mode, but I’m afraid the command efibootmgr doesn’t seem to be available. I hope that helps

and what’s inside the /boot/efi/EFI/qubes/ ?

have you really run the command ?
check again and run in the shell efibootmgr -v

That filepath does not exist for me. I have /EFI/BOOT/, and the contents of that are as shown. Picture of the iso image:

Picture of the contents of EFI:

I am not sure what file you are referring to.

I have run the command. This is after selecting OS rescue mode and pressing c for a shell.

wait not grub one, but qubes os rescue, you need qubes os media installation for that.

I don’t have Qubes installed yet. I’ve got a live USB with a Qubes 4.1 iso that I am trying to install. Are you referring to the USB when you say Qubes OS media installation?

omg my bad, i’ve re-read your post, i was mistaken :pensive:
Maybe this post will help you

I’ve seen this hcl is using the same cpu do you have r4 boot.cfg ?

Oh no problem, we’re all human! I really appreciate the help! I’m determined to figure this out, haha. I’ll make sure to have a look and get back to you, thank you!

Hello 51lieal,

I’m afraid you might have linked the same thread twice, haha. I’ve checked out the thread, and I’m afraid I run into the same problems described in my original post. The file I am supposed to edit is not present in Qubes 4.1, and in Qubes 4.0, I am unable to edit the BOOTX64.cfg file without the file resulting in an unbootable file

So far I’ve been unable to find a thread explaining the steps you have to take to edit the BOOTX64.cfg file in Qubes 4.0 without the file becoming unbootable. The steps listed on the wiki: UEFI troubleshooting | Qubes OS do not seem to work for me. When I mount the USB and type sudo su -, and ls, I only see a file called anaconda-ks.cfg. I don’t seem to have write permissions for editing the BOOTX64.cfg file. When I edit the file like described in How to modify the Qubes-R4.0.4-x86_64.iso, it results in an unbootable file

Okay i believe that grub.cfg is the configuration for BOOTX64.efi

and i’ve found that

Is using same cpu as yours and have i915.alpha_support=1 in boot config, can you try boot again and edit Install qubes* entry then add i915.alpha_support=1

so the configuration is look like this :

maybe it would help.

Thanks for the reply, sorry for my late response. I didn’t know you could edit the boot options like this, thank you! I tried doing this and setting i915.alpha_support=1, as well as noexitboot=0 and mapbs=0 (Thought it might be worth a shot) but it sadly doesn’t seem to work. Thanks anyway! What do you suggest I do now?

change i915.alpha_support=1 with i915.force_probe=* don’t add noexitboot and mapbs, can you try again or add iommu=no-igfx if no success.


You are my hero! I was about to install Arch. The i915.foce_probe=* works! It works! Thank you! Made my day

1 Like