How to install and run Microsoft Teams in Qubes?

Hi. I received a Microsoft Teams link to a video conference. I couldn’t access the conference via Chromium or Firefox because neither have the right requirements. It suggested to install the desktop application. I tried to install the application in Fedora and failed because of missing GPG key. I successfully installed Teams in Debian AppVM (not in the template; temporary install) but couldn’t access the online conference. I got the answer “we’re having trouble finding your meeting” despite the fact that the link is correct. This may be a Debian or Fedora problem rather than Qubes problem. But if anyone figure out how to install MS Teams, let me know. Thank you.

One part of the answer is qubes related: install the software in the template of the appVM where you want to use the software.

the other part is NOT qubes related: install software in linux (fedoora or debian).
Example: (for fedora) How to Install Microsoft Teams on Fedora?

There is nothing to it. Install Teams in the Debian template and then use it in a qube based on it. However, it should have also worked just in Chrome without installing anything. I doubt your issues were Qubes OS or Linux related.

I am using Teams all day long from a debian-minimal based qube. The only special treatment is that I connected one of my 4 USB controllers to that qube so it can see the webcam directly.

I’ve experienced your exact same issue @oijawyuh. Ended up giving up on joining it. (but I don’t recall on which template I tried).

Also, I may add that microsoft really likes their monopoly. So it may be that you need to firefox to “spoof” that you’re using microsoft edge (with an extension like “user agent switcher”).

1 Like