How to edit GRUB options, unable to boot


I installed Qubes today and I tried to set my GPU… long story short, I’m stuck in the boot now with “refusing to continue” and “system halted”.

How do I enter terminal from here to modify grub please, because I modified it and set rd.qubes.hide_pci

I don’t know what to do. I set rd.qubes.hide_pci with the number of my external GPU, but now I can’t boot.
I checked the bios, there’s a property of “Advanced\graphics config”, but there’s nothing I can do there… the “Graphics config” is grayed out and I have only the DVMT Pre-allocated option to set.
I tried to follow this guide but can’t even boot now.

You can edit the GRUB menu entry like this and remove the option that you’ve added:

1 Like

Thank you so much!
I removed the grub value and could boot up, but what are my options with the GPU then right now? My laptop isn’t suitable for this then or maybe there’s something I still can do in order to pass the GPU?

Do you have only one GPU in your laptop? Or two e.g. iGPU and dGPU?

I have two GPUs.

Sorry for not updating you, but I had a silly typo before!
I’m installing standalone now, so excited!

Fingers crossed it’s gonna work!

I can’t install standalone even without the GPU, it gives me an error.

Do I need to disable some things compare to normal installation, maybe disabling bootloader or something alike?

I tried to install endeavouros, but it gives me an error of: The package manager could not prepare updates. The command pacman -Sy returned error code 1.

Maybe there’s some other better OS to try? Manjaro? Or maybe it’s the installation settings I need to tweak?

Would you mind telling us your exact hardware specs — just in case I didn’t miss it?

Besides: building a gaming rig on a qubes based environment seems a bit … well … “daunting” (to me).

Last but not least: arch-based distros are a bit offtopic here.

You need to configure networking manually in your Linux standalone:

I did! I have a network connection.
Also tried to update the keyrings beforehand, didn’t help.

Do I need to do something beyond that? Maybe I need to turn something on or off compare to regular installation without Qubes?

I don’t know about endeavouros but I’ve tried installing debian from ISO and it worked for me without any problem.

I don’t get it… I’m trying with manjaro now, but I have “Limited connectivity” while trying to boot from usb-live.
I did exactly as with endeavouros(I had connection there just fine), but this time with manjaro it connects, but says it’s limited.
I can ping but that’s it, can’t ping anything else nor can go to any website.
Any hints please?

It was a typo again… sorry.

May I ask what your exact goal on the long run is?
Your starting thread was about booting issues.
As far as I understood, you want some gaming setup?

Yes. I do.

If you are just starting on with Qubes, my recommendation is to start with a standalone from the default templates if that’s possible.
Sadly, I am also not too experienced with Endeavouros or Manjaro…
If you take a default one for now, you can focus on your goal on making a gaming vm and see if it’s possible.
Hopefully, you can then port your solution easily to another os, where you can fully focus on creating a new HVM.

I’ve already did half the way, I think.
I can’t figure out why I’m not getting the Nvidia GPU inside my standalone though.
When I check lspci, I see it, but goverlay doesn’t recognize it and selects Intel’s instead.
Maybe someone could drop a hint why this can happen?

Maybe start a new thread for that question?
You (or I if you can’t anymore) can rename the topic of this thread to something like How to edit GRUB to boot? and you could mark the answer of @apparatus as solution.

Are you using separate display connected to your Nvidia GPU?
Did you try to install other nvidia drivers?
Check the logs for nvidia driver errors.

I have a laptop with HDMI, this HDMI works even without Nvidia, I don’t have any other option to attach any other display.
I tried two versions, currently using the latest provided by manjaro, it doesn’t display any number on it though, a bit confusing. It just says “video-nvidia” for the name and “2023.03.23” for the version.