How is it that I cannot find/start my Qubes OS after installing it successfully on an external drive?

So I installed Qubes OS successfully on an external drive a few days ago. Then I unplugged the external drive to continue using the normal windows. Now I’m trying to work on Qubes again but I cannot start it? Basically I’ve a hard time finding the bootable device (i.e., the external drive containing my Qubes OS). I did a quick google search already, and followed the instructions here, but still no use as I just cannot open Qubes

Does someone know how to deal with this?


ps. On this link I’ve also uploaded some images. I can’t do it here so I’ll just leave the link

Read this:

1 Like

Thanks for the quick response! one more question sorry, I’m pretty new to Qubes and how do I open up the command line in which I can type the instructions that you wrote here?

Copy files from /boot/efi/EFI/qubes/ to /boot/efi/EFI/BOOT/:
sudo cp -r /boot/efi/EFI/qubes/* /boot/efi/EFI/BOOT/.
Change filenames grubx64.efi → BOOTX64.efi and grub.cfg → BOOTX64.cfg:
sudo mv /boot/efi/EFI/BOOT/grubx64.efi /boot/efi/EFI/BOOT/BOOTX64.efi
sudo mv /boot/efi/EFI/BOOT/grub.cfg /boot/efi/EFI/BOOT/BOOTX64.cfg

I know how to do that if I’ve my Qubes OS open up, but I don’t know how I can do this in Windows OS or in BIOS. Sorry for the dumb question!

I think you can do this in Windows since EFI System partiton from Qubes OS drive can be accessed from Windows. Just copy/rename files in EFI partition using Windows Explorer.
Else you can boot from some Linux LiveUSB or from QubesOS installer USB in Rescue mode and mount the EFI partition there to copy the files.

1 Like

Thanks for the info, will try, hope it’s gonna work. Wish you all the best bro!

Thanks for the info, will try, hope it’s gonna work. Wish you all the best bro!

Hi disp6252, sorry to disturb you again. So I tried to use Windows but it couldn’t recognize my SSD containing Qubes OS. So I had to create a Qubes installation drive and use the rescue mode.

However, I can’t get to dom0 in the rescue mode. After choosing 1) continue, I get asked to type the password. But even if I typed the right password, nothing happens and it tells me to “Please press ENTER to get a shell”

I press enter, get the shell, but I can’t run the commands that you typed, it simply tells me that "sudo: command not found

Could you help me with this? Or I shuold open up a new thread?

Anyway thx for the time and help really

You can run the commands without sudo there since you’re already root.
You’ll need to mount EFI partition from your Qubes drive fist.
Assuming your Qubes OS drive is /dev/sdb and the EFI partition is 1:

mkdir /mnt/efi
mount /dev/sdb1 /mnt/efi
cp -r /mnt/efi/EFI/qubes/* /mnt/efi/EFI/BOOT/.
mv /mnt/efi/EFI/BOOT/grubx64.efi /mnt/efi/EFI/BOOT/BOOTX64.efi
mv /mnt/efi/EFI/BOOT/grub.cfg /mnt/efi/EFI/BOOT/BOOTX64.cfg
umount /mnt/efi
1 Like

Thanks disp6252 for the quick reply. I managed to run the commands you gave to me without any issue. Now I robooted the PC. Could you kindly tell me if anything shuold be ok now? which file in which directory should I select as my bootable option?

Anyway thanks so much. I’m quite a noob and would have no idea what to do without this forum and experts like you, really knowledgeable. I’ve no idea what each line of code meant but I guess it solved my issues

You can boot by selecting BOOTX64.efi.
But now you should be able to boot into Qubes OS if you select your external drive as first in UEFI boot order without a need to select a specific file to boot.

1 Like

YES! Actually I can already see the option and boot my Qubes OS!

it was just magical

But now I got this error…I guess I messed up something?

Anyway, my original problem has been solved already. So no need for you to answer! Thanks really for the help! Now I might need to try to solve this new error lol

Wish you all the best disp6252