[HCL] - Thinkpad X1 Extreme Gen 4

OS: Qubes OS
Version: 4.1.2
Type: HCL Report

Lenovo Thinkpad X1 Extreme Gen 4

  • Intel Core i7-11800H
  • Graphics: Intel UHD / NVIDIA® GeForce RTXTM 3050 Ti
  • Display: WQXGA (2560x1600) Non-Touch - Best option for longest battery life!
  • Memory: Crucial 64GB DDR4-3200 (2x 32gb) Non-ECC
  • Storage (Two M.2 drives are only available in models with 3050 Ti Graphics!)
    • M.2 NVME Gen 4 (slot 1) - 4TB Crucial P3
    • M.2 NVME Gen 3 (slot 2) - 2TB Crucial P3


  • Built in Wireless Adapter (Intel Wi-Fi® 6E AX210, 802.11ax 2x2 Wi-Fi)
  • Camera/Microphone (Tested: Using Cheese)
  • Video Playback/Sound
  • Function Keys (Volume Controls, Mute, Mic On/Off, Brightness Controls)
  • USB 3.2 Gen 1 (Tested: Sandisk Extreme PRO 256gb)
  • USB C to Gigabit Adapter (Tested: Anker A8313)
  • USB C to 2.5 GB Adapter (Tested: Anker A8316)


  • USB C/Thunderbolt ports (detects external nvme drives, but when attempting to attach to another VM it says it’s attaching but never completes) - Still a problem using 4.2.0 RC3.
  • HDMI Output (tested with Marantz Cinema 40 Receiver & LG G3 TV separately, no output detected)
  • Suspend/Sleep (Cannot wake up, requires hard reset) - Still a problem using 4.2.0 RC3
  • Not sure if this is a problem with the machine or a bug with Qubes, but I’ve noticed an occasional issue where the sys-net will not connect to known wireless networks it’s used before. The sys-net is not configured to be disposable, and the issue is not consistent. If I restart the computer sometimes it will reconnect to an existing wireless network just fine, and sometimes it wont….if it doesn’t I can restart the computer and most of the time it reconnects correctly without me needing to enter another password. If I go to “edit connections” I can see my existing wireless network there with the password saved, if It doesn’t connect automatically and I try to manually connect to the same wireless network it re-prompts for a password, and if I type it in again it saves a duplicate connection. Again, I’m thinking this is more of a bug than a hardware issue because I recall seeing something similar on another laptop long ago. I’ve noticed this behavior on 4.1.2 and 4.2.0 RC3.
    • (I don’t want to get too off topic here, but I’m hoping there may be a way in the future to use sys-net as sort of a gateway “failover” to 2 other network VM’s, one for the physical NIC and another one for the WLAN….this way laptops without onboard RJ45 ports can use a disposable VM for USB connections without it wiping the saved wireless networks used on the machine each time it restarts - I’ve seen a few of the workarounds mentioned in the forums to copy the network config file from the DVM to the template each time you join a new wireless network, maybe there is a more practical solution I’m unaware of?)


  • Bluetooth 5.1
  • SD Card

Other Side Notes…

I purchased this particular computer because I needed at a minimum, 2 physical drives in the computer for a properly separated/encrypted multi boot setup - my previous laptop is a Thinkpad P50 which supported 3 drives. I also wanted a machine that I could charge via USB C for convenience, a decent battery life and something fairly lightweight. I wish all of these things could have been found in a 14” laptop but that’s wishful thinking. This machine was a decent compromise.

Some issues I would like to share, when I ordered this computer I also ordered new NVME drives as well, I went with the 4TB & 2TB Sabrent Rocket 4 Plus drives not thinking anything of it. When everything was delivered I installed the drives only to realize they had chips on both sides of the nvme drive and this laptop requires single sided drives because of the low profile design. The Sabrent drives would technically fit into the port fine, but to screw them down creates tension on the port, at first I thought I could make it work by adding a plastic washer as a spacer where the drive is screwed down, and this appeared to work at first - however, after countless installs and random intermittent errors with a few different OS’s I discovered the cause was the drives were not making full contact in the NVME port - or they would momentarily and then they wouldn’t causing errors and system hangs/crashes. At first I was actually thinking it might be the motherboard, but then I figured I should at least test this with a correct drive….once I used the single sided drives all of the issues I was having disappeared. Hopefully this saves someone else some headaches with any other laptops!

If anyone is curious…

NVME Gen 4 Port (slot 1)

  • Sabrent Rocket (SEQ1M/Q8T1) 5x/1GiB
    • Read: 7011MB/s
    • Write: 6834MB/s
  • Crucial P3 (SEQ1M/Q8T1) 5x/1GiB
    • Read: 4998MB/s
    • Write: 4473MB/s

NVME Gen 3 Port (slot 2)

  • Both drives maxed out at the port capacity 3500MB/s (read & write)

HCL Report.yml


Great report, great laptop according to specs.

S3 Suspend can be working on the latest kernels in Qubes OS, almost all users had issues with suspend on the latest CPUs, including certified laptop.

And hopefully Qubes OS and Xen will support alternative suspend mode.

I have this issue as well, both on my current Thinkpad L14 and my old HP Elitebook 8460p, so I don’t think it’s a hardware issue. On my old one I used to have a second WiFi network confgiured with a lower priority, when it failed to automatically connect to my primary one, it always connected fine to the secondary.
Maybe it has something do to with password length? My primary is 63 characters long.
The secondary (that always connected fine) is a lot shorter. Is your password also very long?

You don’t have to copy the file each time, just once. It’s best to create a separate DVM template for sys-net, and copy the config file to that. Then only the sys-net DVM has access to the config file and other unrelated DVM’s don’t.

For you suspend issue: did you try setting sleep mode in BIOS from Windows+Linux to Linux S3? That was necessary on my Thinkpad.

1 Like

I haven’t really noticed a difference in the behavior with the wireless passkey length. I would like to dig into this some more later.

100% agree!

YOU ARE AWESOME! This fixed the suspend/resume issue!! I feel silly for not checking the BIOS settings now.

(I wish I could edit my original post to add this small detail and credit you.)

1 Like

Thought it would be worth mentioning after doing what I should have done in the first place….checking the forums for answers to my own questions. As it turns out, I did in fact find a better way to do this, and it works beautifully!

Credit to @Sven for the proper solution!

From Sven’s instructions….

  • The only thing I’ll mention I did a little different was I didn’t need to unassign the Wi-Fi card from the devices list on the “sys-net-dvm”, perhaps this is not a limitation in 4.2 RC3? You can’t have both sys-net and sys-net-dvm running at the same time obviously since the computer can only assign the pci device to one vm at a time, in case you’re curious like me, if you do try to start the other vm Qubes will just throw an error saying it can’t connect to the pci device. The only real benefit is one or two less clicks for the rare occasion you need to save a wireless connection. :stuck_out_tongue:
  • I also selected the checkbox option “provides network” under the advanced settings for sys-net-dvm so I could use the network manager to connect to the wireless network in order to create the saved profile. I did unselect this option when I was done just so it wouldn’t show up as a NetVM option in Qubes….I suppose you could leave it if you wanted.

The other beautiful thing about this setup is when using the USB C to Gigabit adapter, simply attaching the usb device to the disposable “sys-net” worked perfectly. This is exactly how I wanted it to work!

  • Disposable sys-firewall
  • Disposable sys-usb
  • Disposable sys-net with configurable Wi-Fi persistence using a dedicated sys-net-dvm.
    No changing file permissions and/or copying files.

So here are my revised steps… in my case, sys-net-dvm is referred to as “AppVM”.

Now you can start sys-net as usual and your wireless profile should automatically connect! :slight_smile:


Thank you @QuberX for your excellent HCL report, which is online now!

I wish more reporters would take the time to provide the detail you have.

I discovered there is something going with the WiFi device. When I go to my saved WiFi network in network-manager, I notice ‘Device’ is set to ‘wsl6’. When it won’t connect automatically, and I connect manually it saves the duplicate connection. When I check the duplicate one the device is set to ‘wsl7’.
So instead of connecting manually I go to my saved connection and change wsl6 to wsl7, and voila, it connects automatically.
I hope someone else knows the answer to the question of why it is suddenly on another device.