HCL - Dell precision 7560

Took a little while but got Qubes 4.1 running on Dell Precision 7560 (also known as ‘la grosse bertha’).

For the OS to be able to boot :

Install the OS. I used debian 11 as default

In order to get sys-net working :

After the first boot, go to sys-net settings (VM must be powered off) and configure strict reset for PCI for the ethernet controller. (sys-net settings → Devices → Configure strict reset for PCI devices → chose ethernel controller)

Shutdown the VM

In order to get the wifi working :

The kernel version was causing problem with the AX210 wifi controller of the laptop

Start debian 11 template.

sudo mv /lib/firmware/iwl-wifi-ty-a0-gf-a0.pvnm /lib/firmware/old.bak

Shutdown template.

My default kernel for sys-net was : 5.15.52 (or 5.15.84, unsure ).

So i went to


and Downloaded the following in a VM

I went to dom0 :

Qvm-run -p personnel ‘cat home/downloads/kernel-5.110.112-1.fc32.qubes.x86_64.rpm’ > kernel-5.10.112-1.fc32.qubes.x86_64.rpm

Do the same for the 3 downloaded files.

Install them one by one with :

sudo dnf instal kernel-XXXX.rpm

Go to sys-net settings, change to the new kernel (Sys-net settings → Advanced → Kernel 5.10.112).

Reboot and get wifi :slight_smile:

PS : I tried with kernel 5.10.104 for sys-net, the wifi was working but there were a problem with a current pop up that was appearing in my top right screen saying : device available and device unavailable. Changing to kernel 5.10.112 fixed it :slight_smile:
I did NOT try all the kernel between the one I had by default and the 5.10.101. I tried updating to latest kernel but wifi did not work

I also add a small issue with my USB keyboard :

Open /etc/qubes-rpc/policy/qubes.InputKeyboard & Add at the top of the file : sys-usb dom0 allow

Qubes-HCL-Dell_Inc_-Precision_7560-20230216-055110.yml (952 Bytes)


Thank you @TibG for your detailed HCL report, which is online now!