Has anyone installed i3wm 4.22

Has anyone been able to successfully install or build i3-4.22 ?

I tried several times. There is this: GitHub - QubesOS/qubes-desktop-linux-i3: qubes rpm for i3
Last time I checked it still was 4.21 and a pull request for 4.22 from Jan 23. It looks like it got merged on April 10th. But I did not try yet to install this. Let me know if you succeed. I didn’t.

You need to build it using qubes-builder.

Here’s how to do it:

  • Clone the qubes-builder repo to a qube of your choice (based on fedora, in /home/user/):
    git clone https://github.com/QubesOS/qubes-builder
  • Install needed dependencies:
    sudo dnf install git createrepo rpm-build rpm-sign debootstrap devscripts dpkg-dev make python3-sh rpmdevtools rpm-sign dialog perl-open python3-pyyaml perl-Digest-MD5 perl-Digest-SHA systemd-container
  • Create a builder.conf file with this content inside:
    RELEASE := 4.1
    include example-configs/qubes-os-r$(RELEASE).conf
    # adjust/uncomment these to build from different branches/repos
    # master branch builds kernel-latest pkgs,
    #  bleeding edge and avoids wrecking your stable kernels
    BRANCH_desktop_linux_i3 = main
    # adjust these for building different pkgs/targets
    # you have to manually resolve the dependencies!
    COMPONENTS = desktop-linux-i3 desktop-linux-i3-settings-qubes builder-rpm
    DISTS_VM = ""
    # mostly needed for kernel builds
  • Get sources:
    make get-sources
  • Remount filesystem
    make remount
  • Build desktop-linux-i3 and desktop-linux-i3-settings-qubes:
    make desktop-linux-i3 desktop-linux-i3-settings-qubes
  • Send the files to dom0 (execute in a dom0 terminal):
    qvm-run --pass-io VMNAME 'cat /home/user/qubes-builder/qubes-src/desktop-linux-i3/pkgs/dom0-fc32/x86_64/i3-4.22-1.fc32.x86_64.rpm' > i3-4.22-1.fc32.x86_64.rpm
    qvm-run --pass-io VMNAME 'cat /home/user/qubes-builder/qubes-src/desktop-linux-i3-settings-qubes/pkgs/dom0-fc32/x86_64/i3-settings-qubes-1.10-1.fc32.x86_64.rpm' > i3-settings-qubes-1.10-1.fc32.x86_64.rpm
  • Install in dom0:
    sudo dnf install i3-4.22-1.fc32.x86_64.rpm i3-settings-qubes-1.10-1.fc32.x86_64.rpm
1 Like

Well if you know, you know. That worked like a charm. Thanks again for wrapping this up.

1 Like