Glitchy screen in qubes, weird dashes in screen. when any new window opens, starts with pixelated dashes

I have installed qubes using this command i915.force_probe=* since the starting i am facing this issue with screen glitch where anything that displays starts with pixelated glitchy dashes and after few seconds the window forms. May be this issue is similar to issue mentioned in the post link below. But that happens int he login screen only but for me it happens with all the screens

Also tried disabling display compositor from window manager tweaker but it does not solve the problem.

How can i implement the solution in the github link above, not sure how to do that.

1 Like

also tried to access xorg.conf file /etc/X11/xorg.conf.d/ Any edits that can be made to the file to solve the issue?

How can I open the Xorg.conf file in qubes?

If you don’t have xorg.conf you need to use the command ‘sudo X :1 -configure’ it will save the current xorg.conf as /root/

I don’t think you can solve the issue by changing the xorg.conf

I think the password screen is made using plymouth, which is a run during the boot process before the x server is started.

@renehoj Yes you are correct, there is no xorg.conf file inside the xorg.conf.d directory. Thought it might be because, maybe the refresh rate or something is not set properly or maybe the graphics card is not detected or set. But as you mentioned this is because the pylmouth is started before the x server. How can this be fixed? and issue is not only with the login screen but any screen that appears and disappears or is active.

If the problem is your x server, then generate the xorg.conf and set the correct device and copy the file to /etc/X11

You can use the arch wiki for more information

The github page you linked talks about a problem with the disk encryption password screen that is unrelated to the x server, which probably currently doesn’t have a solution.

form the arch wiki I found this

Screen flickering

Panel Self Refresh (PSR), a power saving feature used by Intel iGPUs is known to cause flickering in some instances FS#49628 FS#49371 FS#50605. A temporary solution is to disable this feature using the kernel parameter i915.enable_psr=0 .

Where are we suppose to enter the i915 command

Maybe you should read the link you just posted about kernel parameters…

You need to edit /etc/sysconfig/grub and add it to the line GRUB_CMDLINE_LINUX, As root you need to run the command ‘grud2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg’

Thanks everyone for help

@sosqubesinstal can you explain exactly how you solved your issue? I think I am having the same issue as yours. See my thread here:

Can you check my thread and see if the problem is similar to yours. I believe so.
And then, can you tell me what modifications you did on your intel-conf file or the GRUB_CMDLINE_LINUX line in your grub file?

Wrong thread.

what you need to do to fix glitches is to open terminal emulator from the q option menu. Once open type cd /etc after which type ls which will list the directory contents.
Then navigate using cd command to xorg folder , in that folder use command sudo vim filename and vim will open paste the config file content and press esc key and type :wq and then restart.