Visual graphical artefacts on a debian minimal qube

On a ThinkpadX220 laptop, I have a TempateVM which is a debian-11-minimal clone. On that, I have started an AppVM for practicing zshell.

Here’s the setup script for the AppVM, so that you can see the packages added to the minimal template:

qvm-clone debian-11-minimal d11m-zsh

packs="qubes-core-agent-networking pciutils psmisc xfonts-terminus vim man doas rxvt-unicode zsh"

qvm-run --pass-io -u root d11m-zsh "apt install -y ${packs}"
qvm-run --pass-io -u root d11m-zsh 'echo "permit nopass user as root" > /etc/doas.conf'

qvm-run --pass-io -u root d11m-zsh 'dpkg-reconfigure locales'

qvm-shutdown d11m-zsh

qvm-create --label=blue --template=d11m-zsh zsh-practice

My .Xresources file is basically the same as the one example given in the qubes os docs:

I just added a line for dpi scaling:
Xft.dpi: 96

Here are the pictures of the artefacts:

You can see that there are rendering (?) bugs with the fonts. That is, the file name fonts are not fully displayed, they seem to cut at the left-most side.

My hunch with the solution is that I should have the Xresources file preprocessed at the boot time for the AppVM. This is what the rxvt configuration doc is saying.

On the TemplateVM, I have created the /etc/X11/Xresources.urxvt file and I also have created the file /etc/X11/xinit/xinitrc.d/ as instructed on the bottom of the doc. And filled that file with:


[ -r /etc/X11/Xresources.urxvt ] && xrdb -merge /etc/X11/Xresources.urxvt

However the doc doesn’t mention getting that /etc/X11/Xresources.urxvt file executable (i.e., chmod +x), Should that be made executable? Otherwise, the Xresources.urxvt file isn’t affecting my terminal. How can I be sure that that my Xresources.urxvt is getting sourced?

Or any other suggestions to resolve these visual artefacts?

Bump. I want to use Qubes as my daily-driver. So, fixing this visual glitch would be nice.

Edit: The following script doesn’t seem to be executed when starting the AppVM:

From the rxvt configuration guide:

Then create script to automatically merge those to xrdb. File /etc/X11/xinit/xinitrc.d/ :


[ -r /etc/X11/Xresources.urxvt ] && xrdb -merge /etc/X11/Xresources.urxvt

I don’t think the /etc/X11/xinit/xinitrc.d/ script is getting activated, since the AppVM’s terminal is still the default fonts and colors.
How to get it activated during AppVM startup?

Edit 2: I tried adding the if-clause

if [ -r /etc/X11/Xresources.urxvt ] ; then
    xrdb -merge /etc/X11/Xresources.urxvt

to the bottom of the /etc/X11/xinit/xinitrc file. However, the Xresources.urxvt file stil having NO effect. Why is that? Isn’t the /etc/X11/xinit/xinitrc file being executed whenever the AppVM starts? Should I add the aforementioned if-clause to my ~/.profile file?

Hey, since yesterday I’ve been having the same exact problem on all my Qubes, dom0 included

Sorry to hear that. However, I am not having this problem on my dom0. I am having this in a debian-11-minimal qube with Xresources modifications. I mean, running with the default fonts do not cause the above-mentioned (and screenshotted) problems.

I feel like this is a problem with minimal debian’s font settings. This hunch of mine is due to the fact that the normal debian-11 terminal doesn’t have these visual artefacts.

However, I am STILL looking for the suggestions to solve this from the QubesOS community.

Edit: Also, this error happens with the “terminus” font settings. It doesn’t occur with the default fonts of the debian-11-minimal.

Edit 2: Another edit: the visual artefacts problem seem to stem from urxvt, too. Xterm doesn’t have such artefacts.

So, at this point, I am leaning on the hypothesis that the urxvt and the terminus fonts are having some incompatibility issues?

Update: I gave up on fixing this issue. So, I am now using Xterm + DejaVu Sans Mono fonts, which doesn’t have such artefacts on a minimal debian install.