Fresh install, wierd problems. Novice linux user

Hi all,

So I’ve had a wierd series of events happen where:

1.) Tried to use KDE Plasma window manager
2.) dom0 updates happened
3.) After reboot (because dom0… I reboot), LUKS decryption screen is instead a blank (yet still back lit) screen.

I went from 5.10.112-1.fc32 to latest as of 2022-05-27. I have tried CTRL+ALT+F#, modifying grub menu options at boot, forcing 1440p monitor to stay at 1080p… I can type my LUKS passphrase, hit enter, and see my HDD/CPU activity LEDs go nuts. So I assume this is a Xorg/display manager issue…

I’ve tried everything I can find in the forums and in the docs. I either need more hand holding, or some additional suggestions on commands to try.

I can boot back into 5.10 (took me awhile to figure that one out).

Thanks in advance,

I apologize, in my haste to get this finished, I skipped over some details.

I had a working install running on 5.10.112. I had installed KDE Plasma as per a few different articles. Everything was mostly fine, but after doing some tweaks, doing a full backup, and then taking a system update, I was no longer able to see anything on my monitors after the GRUB menu. Just backlit screen.

I tried restoring from backup and while I was in 5.10, the tweaks I made to KDE were causing issues. Unable to figure out how to fix it, and knowing I had backups of each VM, I tried a fresh install.

After fresh install, I’m stuck at 1080p and screen tearing like mad. After sub single digit frames per second, I see I’m stuck at 1080p at 77Hz in my display settings. I am unable to change the resolution or refresh rate (144hz native, supports 30/60/0/100/120/144hz [+/- 0.1]).

I restored my critical VMs, then did a dom0 update to kernel-latest. The first time I installed on the same hardware, my slideshow problem was solved by installing kernel-latest. This time, it updated to 5.16 and I can’t get the LUKS screen to display. A little overwhelmed and frustrated. Caveman bash. Please halp?


Do you have only one GPU?
If you have multiple GPUs (integrated GPU + dedicated GPU for example) then maybe the video output was switched to another GPU.

Gigabyte Z690 UD AX DDR4 + Gigabyte RTX 3060 Ti

Tried onboard GPU, not even backlit. Monitor shuts off due to no signal. Tried a few BIOS options to force onboard. No joy. Great suggestion and if I skipped a step, please tell me.

Did you try to boot with integrated GPU or just plugged out from dedicated GPU and plugged in integrated GPU after boot? What if you try to boot with monitor connected to integrated GPU?


this slideshow is worse than a Cryrix 286DX with OS/2… that OS was supposed to change the world… sigh

Xorg/display manager update shouldn’t be able to cause a problem with LUKS screen.
So you have black screen with kernel 5.16. What about old kernel 5.10? Do you have black screen during LUKS decryption as well?

Nope, using that to ask for help right now.

I can suggest you to try out the kernel-latest 5.17.7 from current-testing repo:
sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing kernel-latest

1 Like

Ok, and when I do this, if I get stuck on a blank screen after GRUB, what do I do? Booting back into 5.10 is easy enough, but that doesn’t fix my issue.

Thanks so much for taking the time tzwcfq!

Then I’d suggest to check if it’s a problem with NVIDIA or some other problem. I’d remove NVIDIA from PC and try to boot with integrated GPU first. If it worked then I’d try to troubleshoot NVIDIA drivers:

Or search around on forum for similar problems with NVIDIA.

Ok, thanks for the tips. Been there, done that. 3060Ti is surprisingly heavy… almost dropped it when I removed it the first time.

Oh, also, I did try the GUI config suggestions in the Docs. This helped a little with the slide show. Maybe 10 fps now. Changing windows is still a 2-3 minute affair.

I am so frustrated. I can download the 4.1 ISO. Install Qubes, get have a slide-show experience. Update GUI config because large monitors. Slideshow slightly better.

After initial install and first round of updates: Kernel 5.10.112
Try an update of the dom0: Kernel 5.16.18, blank screen on reboot after GRUB
Try to install 5.17, I see it briefly in the background script but the screen tearing is so bad, I can’t make it out. Update does not install 5.17, install it says 5.16 is already installed and there’s nothing to do. All I did was take a dom0 update a couple days ago and man that was the WRONG thing to do.

I even did a full backup before the update as a CYA. I can’t even restore that and get back to a stable system. Still a slide show.

Try rescue mode on 5.16, it says it can’t find any linux partitions (REALLY!? I just BOOTED into it!!). What is the point of rescue mode then? warm fuzzy “the feature no one ever uses is in the menu”…

I can’t use it in this state. I have my data, luckily, but I can’t do anything with it. Why can’t I change my monitor resolution? Why can’t I change my refresh rate? I know if I can get to native res/hz, I can at least USE the system.

I just want the pain of using this system to stop. Default UI is painful. Customization is dangerous and leads to an unbootable system. Kernel updates break usability. I’ve only been using this for a month or so. Ok, tantrum over.

I even have to disconnect my mouse because ANY update on the screen brings this system to it’s knees. :frowning:

Did you try to install it with this command?
sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing kernel-latest
Also you can switch to non-gui tty for dom0 terminal with Ctrl+Alt+F2 (F2-F6) and get back to gui with Ctrl+Alt+F1. The screen tearing shouldn’t be in non-gui ttys.


current is 5.10.112
current-testing is 5.16.18 is 5.17.11?

TTY lines are helpful but, I am a novice and have to switch back and forth to the docs for guidance. This is NOT a fun experience.

Qubes dom0 stable repository kernel package kernel version is 5.10.112.
Qubes dom0 stable repository kernel-latest package kernel version is 5.16.18.
Qubes dom0 testing repository ( current-testing) kernel-latest package kernel version is 5.17.7.

Can you copy and paste here the output of this command in dom0 terminal?
sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing kernel-latest

How? I can’t seem to CTRL+SHIFT+C from dom0 terminal. Trying to surf the web is very time consuming if I switch tabs.

Click on the Global Clipboard widget in the tray and you can copy dom0 clipboard to global clipboard by clicking on “Copy dom0 clipboard”.

1 Like

great, gimme 10 minutes for the animation to stop… hopefully clipboard doesn’t time out. I have used that command. It says 5.16.18 is already installed and there’s nothing to do… gimme a few to get the proof for you.