Fedora 36 templates available

New Fedora 36 templates are now available for Qubes 4.1!

Please note that Fedora 36 will not be available for Qubes 4.0, since Qubes 4.0 is scheduled to reach end-of-life (EOL) soon. Fedora 35 is already available for both Qubes 4.0 and 4.1 and will remain supported until long after Qubes 4.0 has reached EOL.

As a reminder, Fedora 34 has reached EOL. If you have not already done so, we strongly recommend that you upgrade any remaining Fedora 34 templates and standalones to Fedora 35 or 36 immediately.

We provide fresh Fedora 36 template packages through the official Qubes repositories, which you can install in dom0 by following the standard installation instructions. Alternatively, we also provide step-by-step instructions for performing an in-place upgrade of an existing Fedora template. After upgrading your templates, please remember to switch all qubes that were using the old template to use the new one.

For a complete list of template releases that are supported for your specific Qubes release, see our supported template releases.

Please note that no user action is required regarding the OS version in dom0. For details, please see our note on dom0 and EOL.

Note for release candidate testers: Qubes OS R4.1.1-rc1 already includes a Fedora 36 template by default, so no action is required on your part.

This is a companion discussion topic for the original entry at https://www.qubes-os.org/news/2022/06/27/fedora-36-templates-available/

I am on Q 4.1 and getting this error when I am trying to install Fedora 36.

Redirecting to 'qvm-template install  fedora-36'
Downloading 'qubes-template-fedora-36-0:4.0.6-202205270243'...
qubes-template-fedora-36-0:4.0.6-202205270243:   0%|                                                      | 0.00/1.72G [00:00<?, ?B/s]Error canonicalizing file: not an RPM package
qubes-template-fedora-36-0:4.0.6-202205270243:   0%|                                                      | 0.00/1.72G [00:02<?, ?B/s]
ERROR: [Errno 2] No such file or directory: '/root/.cache/qvm-template/tmpenf9uwg4/qubes-template-fedora-36-0:4.0.6-202205270243.rpm.UNTRUSTED'

in fact there is nothing on /root/.cache/qvm-template/ and looks like I am not downloading anythings. Any recommendation on how to debug this error? I tried nyx on sys-whonix and looks like I am not downloading anything.


Same here. Also Qubes OS 4.1

I installed the template using qvm-template-gui which worked for me.

Hi, same problem here, also 4.1.

Now the updater indicated that I need to update Dom0, so perhaps that fixes the problem. Stay tuned. Updating Dom0 now first…

Nope, still the same problem after Dom0 update. The fedora-36 template cannot be downloaded.

Nope, same error here via gui.

Strange, I installed the template 1h ago without any issue.

Yes, I thought this is the issue but after updating Dom0, i am still getting this error.

1 Like

Idem with minimal:

Downloading 'qubes-template-fedora-36-minimal-0:4.0.6-202205270243'...
qubes-template-fedora-36-minimal-0:4.0.6-202205270243:  40%|████      | 293M/724M [24:20<35:55, 200kB/s]
Error canonicalizing file: Payload forged!
ERROR: [Errno 2] No such file or directory: '/home/bruno/.cache/qvm-template/tmpdyt6dn91/qubes-template-fedora-36-minimal-0:4.0.6-202205270243.rpm.UNTRUSTED'

Can it be a network latency problem (very slow network here)?

Found this:

It seems specific to 36 - other templates can be installed or

Yes, looks like this is the case. I can download other templates.

Same here. And tried to use sys-whonix too (over tor) with the same exact issue.

same issue (no proxy/vpn/tor)

I had this error using qvm-template-qui, but success on retry. On other machine, no error.

I had this error using qvm-template-qui, but success on retry. On other machine, no error.

Amazing and at the same time wired, but qvm-template-qui works. at least I am seeing that I am downloading but it is very very slow.

The other wired thing is that I am not able to update my VMs and Dom0 on GUI but I can do that by right click on VM name in Qubes Manager, and now command line is no good for installing template but GUI is working fine. Just wired.

Update: No! it did not worked. I am having this error now:

Downloading 'qubes-template-fedora-36-0:4.0.6-202205270243'...
qubes-template-fedora-36-0:4.0.6-202205270243:   9%|▉         | 152M/1.72G [38:13<6:33:51, 66.3kB/s]
Error canonicalizing file: Payload forged!
ERROR: [Errno 2] No such file or directory: '/home/sa/.cache/qvm-template/tmpv28slbbl/qubes-template-fedora-36-0:4.0.6-202205270243.rpm.UNTRUSTED'

did you expand the dom0 root space?