Fedora-36 networking fail after uninstalling unneeded apps

I installed the fedora-36 a couple days ago and switched sys-net over to this without issue (other than the template failing to download ~5 times). This is the full fedora-36 (not minimal). sys-net was able to connect to my Wi-Fi network without issue, even after a reboot.

However, when I booted up today, I discovered that sys-net will no longer connect to my Wi-Fi network. All other devices will - this isn’t an issue with my network. Yesterday, only two things changed with my Qubes OS v4.1 installation:

  1. dom0 received an update
  2. I uninstalled the following apps via the Software app from fedora-36 because I have no intention of using them:
    1. Calendar
    2. Cheese
    3. Contacts
    4. Document Scanner
    5. Maps
    6. Parental Controls
    7. Thunderbird
    8. Weather

If I switch sys-net back to fedora-34, it will connect to my Wi-Fi without issue, so it appears that uninstalling the above apps has somehow broken fedora-36 networking. Does anyone have any idea why and what the cleanest way to fix this would be? Is there any kind of qubes repair command that I can run that will check for and install missing, critical packages?

Not that anyone’s dying to know, but I did make some progress on this issue:

  1. I noticed that fedora-34 had NetworkManager-wifi and wireless-tools packages, but fedora-36 did not
  2. I installed NetworkManager-wifi in fedora-36, but am unable to install wireless-tools for some reason:
    1. sudo dnf install wireless-tools
    2. No match for argument: wireless-tools
    3. Error: Unable to find a match: wireless-tools

Even though I was unable to install wireless-tools, networking appears to be working again in using fedora-36 for sys-net. However, considering this was working before I uninstalled the 8 apps referenced earlier, this begs the questions:

  1. Why would uninstalling these apps from the Software app uninstall NetworkManager-wifi (and its dependencies: iw, wireless-regdb, wpa_supplicant) and possibly wireless-tools?
  2. Why is wireless-tools package unable to be found in fedora-36, noting that it is installed in my fedora-34 template? This is not a connection issue because I installed NetworkManager-wifi in the same session.
1 Like

Thunderbird has a qubes specific plug-in that when removed erases a bunch of qubes dependencies. Removing it will break your system.

Look for any qubes packages that were removed and reinstall them manually.

How would I know which ones were removed? Is that logged somewhere, or is there a list of what packages should be there? One of the reasons why I ask is because I see that fedora-34 had wireless-tools, but fedora-36 does not. When I try to install wireless-tools, I get the following in fedora-36:

  • No match for argument: wireless-tools
  • Error: Unable to find a match: wireless-tools
concerned
July 28

How would I know which ones were removed?

Here is what I would try:

dnf search thunderbird | grep -i qubes
To find the thunderbird plug-in name.

Then do:

dnf install thunderbird
But type ‘n’ to cancel that install.

Make note of any qubes related packages listed on the screen that would have been installed if you had typed ‘y’ for that install.

Finally do:

sudo dnf install
Make sure to leave out the name of the thunderbird plug-in from that prior list.

This should add back just the qubes specific dependencies that had been erroneously removed. I’m not sure why these qubes dependencies get uninstalled in the first place. But if you are better than me with dnf/rpm you might just be able to query the thunderbird package dependencies directly and skip a few of the above steps. I never tried it that way. I only made this mistake once, and that was enough, so my memory of the specifics is not so great.

Hope this helps.

There’s a lot going on here that you haven’t explained.
How were you able to get Software working in the template? (It’s never
worked for me because it doesn’t handle the Proxy setting correctly.)
You did not give sufficient detail about the way in which WiFi did not
work.

Removing those packages with dnf, leaves a fully functioning sys-net.
Either “Software” does something odd, or you’ve not mentioned some step.
You can look in /var/log/dnf.log for relevant entries.

wireless-tools isn’t available in the main repositories - look here:
https://fedora.pkgs.org/36/trinity-r14-x86_64/wireless-tools-29-28.fc36.x86_64.rpm.html
You don’t need that package to have functioning WiFi in 36.

The Software app will let you uninstall apps. I figured that would be easier since I didn’t know what the package names were (e.g. what is Parental Controls?).

As I stated in my initial post, Qubes would no longer connect to my Wi-Fi network. I’m not sure how much more specific I could be. When I boot up the machine, it either connects (automatically), or, in this case, it does not.

Perhaps when Software removed one of the packages (slcoleman believes Thunderbird), it removed NetworkManager-wifi for some reason. However, what I can say with certainty, is I listed all steps. Wi-Fi was working, then I uninstalled these packages and rebooted, then Wi-Fi was no longer working and I noticed that NetworkManager-wifi was missing.

I agree maybe Thunderbird removed one of the dependencies.

These are the dependencies I’ve found to get ethernet and wifi to work correctly from a fedora-36-minimal.

Note: iwlax2xx-firmware is Intel AX2xx wifi specific hardware.

dnf install qubes-core-agent-networking qubes-core-agent-network-manager qubes-core-agent-passwordless-root qubes-core-agent-dom0-updates gnome-keyring notification-daemon NetworkManager-wifi network-manager-applet iwlax2xx-firmware