Fedora-34 issues with sys-net and vpn VM

I installed fedora-34-minimal, updated it, and installed in it the basic software that I had in fedora-33-minimal (qubes-core-agent-networking qubes-core-agent-network-manager iptables openvpn pciutils vim-minimal less psmisc iproute qubes-core-agent-dom0-updates NetworkManager-wifi network-manager-applet wireless-tools qubes-input-proxy-sender qubes-usb-proxy).

Then I switched sys-net, sys-firewall and vpn VM templates from fedora-33-minimal to fedora-34-minimal template. sys-net failed to boot up. I switched it back to 33 Template and it booted. sys-firewall worked fine. The VPN in the vpn VM failed to launch. I switched back to 33 Template and the VPN worked.

Has anyone else experienced these difficulties? What am I missing?

Thank you.

This is the notification that I received when I make sys-net template fedora-34-minimal with the same packages (listed above) as fedora-33-minimal:
2

change default mgmt vm to fedora 34 / fedora-34-minimal then install required package.

default-mngmt-dvm had already been se to fedora-34. All templates have been switched to fedora-34 or fedora-34-minimal, but I had to revert back sys-net and vpn-vm for both to work.

So I tested Fedora 34, after attempting Fedora 34 minimal, and, to my surprise, neither sys-net booted, nor the VPN kicked in in the VPN VM (after I had reverted sys-net to Fedora 33).

I have Thinkpad Carbon X1 Gen. 8.

Is anyone else facing these problems or am I the only one facing them? Can anyone recommend how I can diagnose and fix this?

I have the same issue. everything is on fedora 34 except sys-net.
Here is log from it. For me it looks like Intel(R) Wireless WiFi driver for Linux driver error but have not figured out how to fix it.
guest-sys-net (copy 1).log (58.2 KB)

@khisanth I found the solution by switching to Debian 11.
I downloaded the debian-11 template, and installed openvpn in the template, and switched sys-net, sys-firewall and VPN VM to debian-11 template. Everything worked (so far). I guess this means I need to stop using Fedora for these three VMs.

Is this the same even when changing to the kernel that the template has? That is, sys-net will have the following settings:

qvm-prefs sys-net kernel ""
qvm-prefs sys-net template fedora-34

HI. I did not understand your question, @kommuni. I do not have advanced IT knowledge.