VPN not working with Fedora 34

Hi there,

after I updated to Fedora 34, all my VPN-service-qubes are not connecting anymore. With Fedora 33 they worked without any problems. I used https://github.com/tasket/Qubes-vpn-support to create several qubes working with Mullvad VPN. Whats’s wrong?

Hi. Welcome to the forum!
I raised the same issue here:

I haven’t gotten an answer and wasn’t able to fix it while keeping Fedora.
I switched the VM Template to debian-11 (and installed OpenVPN in the template) for the VPN to work again. Also, I failed to get the VPN to work in debian-11-minimal despite installing all packages possible.
Switching to debian-11 could be a temporary solution until a fix is found.


Thank you! I’ll try that

1 Like

I use a combination of debian 10 and 11 minimal depending on the vpn provider.

I had similar issues with OpenVPN, so I switched to WireGuard. If you have that as an option with your provider, here is how I accomplished it (with awesome community help) New user confused on vpn stuffs

Haven’t had any issues with it so far.

Currently investigating tunnel “locking” mechanism for certain VMs.