Failed to Install on TUXEDO InfinityBook S17

i just got an TUXEDO InfinityBook S 17 - Gen7 with

  • Intel Core i7-1260P (max. 4.70 GHz | 12 Core | 16 Threads) | Intel Iris Xe Graphics G7
  • Intel Wi-Fi 6 AX200 (802.11ax | 2,4 & 5 GHz | Bluetooth 5.2)

I used the Qubes-R4.1.2-x86_64.iso on an USB-Stick for installation.

The boot-process logs are the following:

dracut-pre-udev[644]: modprobe: FATAL: Module cramfs not found in directory /lib/modules/6.1.12-1.qubes.fc32.x86_64
dracut-pre-udev[695]: modprobe: FATAL: Module floppy not found in directory /lib/modules/6.1.12-1.qubes.fc32.x86_64
[OK]  Started **Show Plymouth Boot Screen.**
[OK]  Started **Forward Password Requests to Plymouth Directory Watch.**
[OK]  Reached target **Local Encrypted Volumes.**
[FAILED]  Failed to start **udev Wait for Complete Device Initialization.**
See 'systemctl status systemd-udev-settle.service' for details.
         Starting **Device-Mapper Multipath Device Controller...**
[OK]  Started **Device-Mapper Multipath Device Controller.**
[OK]  Reached target **Local File Systems (Pre).**
[OK]  Reached target **Local File Systems.**
         Starting **Open-iSCSI...**
         Starting **Create Volatile Files and Directories...**
[OK]  Started **Open-iSCSI.**
         Starting **dracut initqueue hook...**
[OK]  Finished **Create Volatile Files and Directories.**
[OK]  Reached target **System initialisation.**
[OK]  Reached target **Basic System.**

Before the FAILED-Message it stuck about 2 minutes. At the last OK-message the system freezes.

I tried from adding by editing the use-last-kernel-option in the grub menu an aing dom0_max_vcpus=1 dom0_vcpus_pin=1 from Qubes on Ryzen 7 pro 6850U elitebook 845 g9 - #5 by Cpotts without any changes

I tried to addin irqpoll according to GPD Win Max 2 - Unable to boot installer - #4 by lrvick.

Now i think my hardware is incompatible with qubes at the time.

Does anyone has additional tipps to got the installation?

I am grateful for any help!

try using qubes 4.2

I have that exact laptop and used the same .ISO. did you boot the PC in the newer GRUB?

Sorry, i dont understand. I dd-ed the iso to the USB-Stick. How can i use another GRUB?

thanks for the advice. I will try the newer test-iso .

Do you have RAID enabled in BIOS?

with Qubes-4.2.202305221524-x86_64.iso nothing changed, same FAILED on Device Initialization and freezing at

no, i have 2 ssds but without a raid.

Just to make sure, even if you didn’t specifically configured the RAID for your drives, in some BIOS it’s the default SATA mode:

My Bios looks like that:

I have only the possibility to create a raid-1 or a raid-0, but cannot choose an AHCI-Mode.

I don’t know about this specific BIOS, you can try to find your BIOS manual and see if the default SATA mode is AHCI or RAID and maybe there’s a way to change this hidden option somehow.
Related issue:

When booting initially, there is an advanced boot screen that should allow you to toggle between the stable or latest kernel. Choose the latest kernel.

Since you have the same computer as me, you should also have the same BIOS. Have you changed any settings for the installation?

I have only deactivated the Intel Management Engine.

thanks for your advice. i will try to find a manual for the BIOS.

I did not change anything, Qubes booted on the computer with no changes to the BIOS. The only thing I did was when the computer initially booted with the qubes USB, was select the newest kernel.

Thanks @Cpotts

I played around with the bios a bit and tried RAID for a short time. I then switched it off again. Maybe I shouldn’t have done that and something was changed that I can’t reset via the BIOS GUI.

I only found a white paper on I asked Tuxedo for a BIOS manual.

I thought that if I bought this computer I would be able to install Qubes. If nothing turns up, I’ll probably have to do without Qubes.

You can try to reset BIOS to factory defaults.

1 Like

Even a factory reset does not lead to any change in the installation behaviour.

Can you check the boot log for more precise errors?
[OK] Reached target **Basic System.*
If you wait for some more minutes then dracut will timeout and you’ll be able to enter shell to get the logs.
Like this:

I have now waited half an hour after the “reached target basic system”. No further messages came. I then pressed STR-ALT-DEL and more messages appeared (see screenshots).

More “completion polled” messages then appear, but the system does not restart.

There is also no shell prompt.