External monitor: Can not click within Qube windows, but can click on desktop [SOLVED]


X230 with an external 1920 x 1080 monitor via VGA.

No external mouse or keyboard attached.

The monitor works, the desktop is extended, and I can drag VM windows across to it from the laptop monitor.

I can move, maximize, minimize, and resize windows on the external monitor, which shows that clicking on that monitor in general does work.

However no clicks are registered within any VM windows on the external monitor. E.g. I can’t place a cursor within a text editor or do anything else that requires a mouse click within an app window.

What especially does my head in is that yesterday when I tried to use the external monitor for the first time I had the same issue, but after setting the external monitor to 75Hz and then back to 60Hz, for some reason the problem was gone, and I was able to click within app windows on the external monitor - but I can’t replicate that fix now, so might have been coincidental timing, and in actuality something else caused it to work yesterday.

I read here in the forums and in the documentation about external monitors to the best of my ability, but can’t seem to find the solution to this.

What are things that I might be overlooking here?

Any pointers how to solve this would be much appreciated.

Have a nice day! :slight_smile:


PS: Mouse works perfectly on the laptop screen, including clicking, including even an external mouse, when I attach that. (The issue described above happens whether there is an external mouse attached or not.)

This is something that I’ve also encountered. Generally, restarting the affected qube(s) gets them to properly register mouse clicks.

This seems to occur whenever new monitors and the screen resolution changes. For some reason, the qube(s) do not properly update. This leads to the mouse either not working or for the clicks to register in the wrong location.

1 Like

Thank you! This did work. I will make a mental note for future issues to consider the “have you switched it off and on again” thing. Well this was an easy one. Thanks heaps!

1 Like

This will also fix it if you don’t mind “getting your hands dirty”, or if you want to know why restarting the Qube works:

Hi @alzer89 thank you for pointing this out.

I had already read this, but though it’s not applicable in my situation - can you tell me if I’m wrong with that?

“By default, it is as much as needed for the current display and an additional full HD (FHD) display (1920×1080 8 bit/channel RGBA).”

Since my external display is actually only 1680 x1050, wouldn’t the default be enough, without manually changing it?

My laptop screen itself is 1366 x 768.