Exotic OSes which I tried on Qubes

I decide to write a list of exotic OSes which I tried install as HVMs with a quick summary of what is working. Don’t know why I have such phase to try new systems on Qubes while on Virtualbox not tried nothing that I don’t need.

Totally Exotic:

TempleOS - infamous work of one man (with diagnosed schizophrenia).
Generally can be installed from the ISO and seems to work (I’m not testing sound which for those who want to hear random tunes from the God himself may be crucial). Have problem with cursor like many HVMs. I also not tested if passing through flash drives works.

ReactOS - Windows NT like open source OS. It’s goal was to be compatible with Windows NT.
Can be installed but there is the bug in the installer that causing boot crash when isntalled with networking. Workaround is to install it without networking and setup network connection later. Works good. Like windows HVM.

SerenityOS - Open source OS with feel of old Windows and Macs (from the 90s). Start as project which helping his creator recover from addiction. Then maintained with growing community. Like in TempleOs many thing are implemented from scratch. Can be build and run in QEMU inside VM. Unfortunately I can’t make it work on Xen. I create disk img with grub installed, and copy it rootimage of freshly created HVM. Grub works but system hangs on boot without any error… I also tried expending size of image to 10GB and create HVM from image with the same effect. Changing qvn gui features also changed nothing.

Plan9 - next generation of unix from the Bell Labs.
Can be installed (use VESA for graphics). Have problems with cursor.

9Front - still maintained (by some strange free speech organization from Germany that run its servers on it) fork of Plan9.
Can be installed. Works good.

Exotic Linux Distros:

PLD - PLD LInux Distribution (formerly Polish Linux Distribution). Hardcore Linux distro from the beginning of millennium. Still maintained. I can’t make it work. I can install it from live cd but is too old to upgrade the system. From the installation cd I can’t figured out dependencies so the installation fails. When trying to convert from (also rather old) virtualbox image it fails to boot (can’t mount hdd - maybe converting virtual drives to scsi will help).

EasyOS - from the creator of Puppy Linux. Concept similar to Qubes but container based. Its container engine is written from scratch. Can’t run it. Best result was booting img using Ventoy, but graphic drivers fails to load.

Skywave Linux - Ubuntu remix concentrated on SDR. Boots normally as Ubuntu. Can’t be installed in normal way since Calamares and Ubiquity are broken for that project. Script to clone it using rsync maintained by its creator seems not work properly.

Pentesting/Forensics/Security:

BlacArch - it is possible to add blackarch repo to archlinux qubes communit template and install all the tools. Some tools not works.

Pentoo - it is possible to add overlay to qubes gentoo template. Unfortunately Gentoo is to nerdy for me and I pass when encountered some funky dependencies problem.

Caine - forensics Ubuntu remix from Italy. Newest version have broken installer. Previous version have less broken installer so it can be installed but it is based on ancient Ubuntu and updates fails on dependencies.

BackBOX - fails to boot.

Tails - can boot using ventoy. It is rather pointless to use it on Qubes.

REMnux - malware analysis ubuntu remix. Morphing qubes ubuntu template fails. It is possible to morph normal Ubuntu HVM. Not tried to convert VM image.

If someone have idea how to progress with one of the OSes which fails I will be grateful for advice.

8 Likes

For 9front there is also GitHub - santucco/9xen. If I figure it out how to build it i will try it.

1 Like

I’m missing Haiku on your list :wink:

4 Likes

And after that and
https://bedrocklinux.org/index.html

the only thing to try would be…

I know you know

yes, Qubes on Qubes

2 Likes

I must to try both of them. Also thinking on Inferno as a side branch of Plan9 evolution.
I’m most curious what stopping SerenityOS from boot on Xen. I suspect some graphic issue. I opened issue on their github but I was ignored.

1 Like

I saw that someone did it with 3.0

Bedrock won’t start on debian creating a template or if started no app can be started. Probably to try to create standalone in debug mode to check what is going on…

Just checked it. After hijacking and reboot, apps not work as you said.

1 Like

As I can remember when trying it in Virtualbox there was some first-time screen before log-in about setting bedrock on the first boot. Most probably that’s the reason, but don’t take my word.

@Szewcu this definitely belongs in the main forum section (since it’s about Qubes). Moved it there.

1 Like

Ok, I wasn’t sure if trying different OSes as HVMs just for fun deserves topic on main forum. Most of them is just useless or not adding any value to Qubes installation.

Two more exotic systems:

Q4OS
debian-based system offering trinity desktop which is similar to Windows XP or newer. Stable and rather fast. Could be installed as a template in HVM mode, but so far no qrexec is available.

kolibri
A tiny system that fits on a floppy disk. Can be booted from an image file (like Tails). Just for fun - there are some games on it. :grin:

3 Likes

You would try running QNX Neutrino

1 Like

Created standalone debian-11-minimal, then installed Bedrock in it, restarted in debug mode, shell didn’t report any error or additional action needed by Bedrock, and the qube couldn’t start as well, with the qrexec error reported in dom0. So, I increased qrexec timeout, and bam, it was there.

Went back to debian-11-minimal-bedrock template in PVH mode, increased its timeout to 600 and bam, it was there too! Terminal thunar all are there working…

Updated via apt and apt-cacher-ng flawlessly, and trying now to check other packagers…

$ brl tutorial basics

works as expected, so I’m definitely in Bedrock.

That is all that I checked so far

1 Like

You might try Redox OS
Latest images with installer

2 Likes

Is there any fix for those unsynced cursor?

Hi there,
on Q4.0.4 I installed XigmaNAS.
Cheers,
M.

I am sorry but I have a strong feeling of ReactOS as the most wasted time in some dev’s life… Never moved from alpha stage after… how many decades? Really?

1 Like
Offtopic

Moderation policies and flagging and hiding posts