Error when running qubes-builder : Unable to detect release version use '--releasever'

Hey, I was trying to build an iso, and I followed the steps in the qubes-builder guide, but I’m still unable to get past this … I’m not entirely sure where to insert the --releasever flag, as stated by the output log.

(Unrelated) I tried running the public alpha image on the ftp servers, but the xserver doesn’t start on this hardware. It works just fine on my other laptop tho. (I’m running a ryzen 4900h with amd integrated graphics, if that’s helpful)

[user@localhost qubes-builder]$ make qubes
Currently installed dependencies:
make[1]: Entering directory ‘/home/user/source/qubes-builder’
[sudo] password for user:
-> Preparing fc32 build environment
Unable to detect release version (use ‘–releasever’ to specify release version)
Error: Failed to download metadata for repo ‘fedora-modular’: Cannot prepare internal mirrorlist: Status code: 404 for$releasever&arch=x86_64
make[1]: *** [/home/user/source/qubes-builder/qubes-src/builder-rpm/Makefile-legacy.rpmbuilder:44: /home/user/source/qubes-builder/chroot-dom0-fc32/home/user/.prepared_base] Error 1
make[1]: Leaving directory ‘/home/user/source/qubes-builder’
make: *** [Makefile:254: vmm-xen-dom0] Error 1

It appears you are building from a Fedora 33 build VM?

What is the output for:

make DIST_DOM0=fc32 DEBUG=1 prepare-chroot-dom0

It gives me this output … Should I instead use a Fedora 32 build?

make --no-print-directory DIST=fc32 PACKAGE_SET=dom0 -f Makefile.generic prepare-chroot || exit 1;

This is already fixed in
Fetch new sources (make get-sources).

I’m having no luck at all building Qubes 4.1 from main Qubes repository. Getting the same error. I’m trying to do a simple build to test compatibility (fc32 dom0 with master kernel - no other templates). After about an hour, at what I suspect is the final stage of the build, it fails.
I’ve tried building on fc32 and fc33. Same outcome.

→ Building template fc32 (logfile: build-logs/template-fc32.log)…
make: *** [Makefile:341: template-local-fc32] Error 1

Here’s the build-logs/template-fc32.log
template-fc32.log (28.6 KB)

(Replaced the pastebin link with a local upload - just dragging and dropping .log files onto the forum like an attachment. I hope that’s ok)

Thanks for that. I should have done this myself.

Update about my post - I managed to build successfully by omitting any template, and instead only building dom0 fc32.
The issue now is the ISO for 4.1 doesn’t work.

I can confirm that I’m still getting this issue today (after running make get-sources). I also had never even downloaded qubes-builder before I cloned the repository yesterday, so my code must be fresh.

I am getting the error using the default qubes-os-r4.1.conf and running make qubes-os-iso. It seems to be triggered by any target which requires the target template-local-fcXX though.

I can also confirm that I checked the relevant file at qubes-builder/qubes-src/builder-rpm/prepare-chroot-builder for the change listed in that commit that supposedly fixed the problem, and can confirm that my line 31 says YUM_OPTS="$YUM_OPTS --releasever=${DIST_VER}"