Error updating fedora-39-minimal

[irrelevant comment retracted]

Related issue on github:

Thanks @DVM . I’m on R4.1 but the last comment in the Github issue sums it up nicely :slight_smile:

Rudd-O commented last week:

The quality of the SaltStack code base makes me think it’s a miracle this thing even works. I regret betting on this horse years ago.

[irrelevant comment retracted]

That’s more a salt issue than a Qubes issues.
Have you tried this:

What is the current salt version in the management template?

I’m on 4.1, as I said. The github issue is strictly about 4.2.

The issue is about salt and fedora 39 using python 3.12.
What is your salt version in the template?

[irrelevant comment retracted]

I downloaded and created a new fedora-39-minimal template on my Qubes 4.2 system. I’ve been able to replicate the issue:

ModuleNotFoundError: No module named 'urllib3'

I installed python3-urllib3 in the template, tried again with salt and it worked.
Can you check if you have this package installed in your minimal template?

[irrelevant comment retracted]

1 Like

Hello, how to download…fedora 39 ? in what terminal and what command? and how to createa new fedora 39 template ? I am also on qubes 4.2

Search for “Qubes Template Manager”, you will get a GUI with all available templates. If you have made changes to the old template and want to keep them, do an in-place upgrade instead.