Error Updating Dom0

When i run software update for Dom0 (qubes → qubes tools → qubes update) or use dom0 terminal the process occurs - i download a ton of updates (i am currently on 4.1) and then when it is time to install them (click y confirmation) and then i get

Running 'usr/lib/qubes-qubes-download-dom0-update.sh --doit – nogui ‘–exclude=qubes-template*’ ‘–quiet ’ ‘-y’ ‘–clean’ ‘–action-upgrade’’ on sys-firewall

Error: Transaction test error

file /usr/lib.build-id/10/426e215ebe20c86b885515b0c3a93284e0a68 from install of kernel-devel-1000:5.10.96.1.fc32.qubes.x86_64 conflicts with file from package kernel-devel-1000:5.10.76-1.fc32.qubes-x86_64

^^ i get the above for about 20 other files

and then a big fat x next to dom0 indicating a failed update.

anyone can help ? :innocent:

I’m not that familiar with salt, but I ran into a similar error when trying to upgrade dom0 with the qubes updater after manually installing kernel-devel. I’m still looking into the best way to fix it, but as a workaround you can manually uninstall kernel-devel from dom0, update dom0, then reinstall kernel-devel.

In my case, I followed these instructions to install librem-ec-acpi-dkms in dom0: Install librem-ec-acpi-dkms in Qubes ($1170) · Snippets · Snippets · GitLab

Removing kernel-devel also removed dkms and I had to reinstall both and rebuild the module. If this is why you installed kernel-devel you can follow these steps:

sudo qubes-dom0-update --action=remove kernel-devel

sudo qubesctl --show-output state.sls update.qubes-dom0
sudo qubes-dom0-update --clean -y
Reboot (you’ll need to resign your boot partition, choose a new default boot kernel and resign again in pureboot).

sudo qubes-dom0-update dkms kernel-devel
cd librem-ec-acpi-dkms-master

Edit dkms.conf and increment the package version to a new number like 1.1

sudo dkms add ./
sudo dkms build librem_ec_acpi/1.1
sudo dkms install librem_ec_acpi/1.1
sudo systemctl enable dkms

Reboot and you’ll have to go through resigning in pureboot again.

There’s probably a better way to solve this but I need to spend more time looking into it. If you installed kernel-devel for some other reason you might need to reinstall/reconfigure whatever needed kernel-devel.

Please consider it is not enough at the moment, most probably.

https://forum.qubes-os.org/t/understanding-qubes-updater/9688/9?u=enmus

I’ve edited my post to include the mitigation.

hmm, using the qubes update tool, all i see is “next”, something doesn’t sound correct.

is it possible to give dom0 more Ram or Harddrive space?

Yes, see Global Settings in Qube Manager.

I have tried commands both 1 & 2 in dom0 and the same error in the original post in this thread persists. the updates are not being installed.

just bumping for one last hail mary for any help on this before i do a complete wipe and reinstall from scratch. anyone?

I meant ewokky should, not is it possible in general.

so does this mean ewokky is doing something advanced with kernel development packages?

when I use gui qubes updater, I just see “next” button, eg not what ewokky referenced, sorry for confusions

1 Like

Doesn’t look like a problem with the Qubes Update tool or Salt update system itself. Rather, it looks like the problem is this set of package conflicts with kernel-devel. If you ever installed any packages in dom0, that might be why this happened. I don’t know any more than that, sorry.

1 Like

Is @frank_sullivan’s post visible? To me, it is.