Domain failed to start: Cannot connect to qrexec agent

This is happening to me on both the Template and AppVMs based on the template, based on Debian 10 (full, not minimal).

I get the error:

Domain VMNAME has failed to start: Cannot connect to qrexec agent for 60 seconds, see /var/log/xen/console/guest-VMNAME. log for details.

The tail end of the log shows:

[.[0;32m  OK  .[0m] Started .[0;1;39mAdjust root filesystem size.[0m.
[    3.722875] xen_netfront: Initialising Xen virtual ethernet driver
[.[0;32m  OK  .[0m] Found device .[0;1;39m/dev/xvdc1.[0m.
         Activating swap .[0;1;39m/dev/xvdc1.[0m...
[.[0;32m  OK  .[0m] Started .[0;1;39mInitialize and mount /rw and /home.[0m.
[    3.772247] Adding 1048572k swap on /dev/xvdc1.  Priority:-2 extents:1 across:1048572k SSFS
[.[0;32m  OK  .[0m] Activated swap .[0;1;39m/dev/xvdc1.[0m.
[.[0;32m  OK  .[0m] Reached target .[0;1;39mSwap.[0m.
[    3.782616] Error: Driver 'pcspkr' is already registered, aborting...
[    3.844844] xen_netfront: backend supports XDP headroom
[.[0;32m  OK  .[0m] Started .[0;1;39mMonitoring of LVM2… dmeventd or progress polling.[0m.
[.[0;32m  OK  .[0m] Reached target .[0;1;39mLocal File Systems (Pre).[0m.
         Mounting .[0;1;39mMount unit for cmake, revision 858.[0m...
         Mounting .[0;1;39mMount unit for core18, revision 1997.[0m...
         Mounting .[0;1;39mMount unit for cmake, revision 870.[0m...
         Mounting .[0;1;39mMount unit for core, revision 10958.[0m...
[.[0;1;31mFAILED.[0m] Failed to mount .[0;1;39mMount unit for cmake, revision 858.[0m.
See 'systemctl status snap-cmake-858.mount' for details.
[.[0;1;31mFAILED.[0m] Failed to mount .[0;1;39mMount unit for core18, revision 1997.[0m.
See 'systemctl status snap-core18-1997.mount' for details.
[.[0;1;31mFAILED.[0m] Failed to mount .[0;1;39mMount unit for cmake, revision 870.[0m.
See 'systemctl status snap-cmake-870.mount' for details.
[.[0;1;31mFAILED.[0m] Failed to mount .[0;1;39mMount unit for core, revision 10958.[0m.
See 'systemctl status snap-core-10958.mount' for details.
You are in emergency mode. After logging in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" or "exit"
to boot into default mode.
Press Enter for maintenance

I have looked at similar reported issues and tried increasing the initial memory all the way up to 1000MB, but the error and results in the log are the same. I have over 700GB on the Qubes disk available, so space doesn’t seem to be a problem.

I tried restoring several backups of the Template going back to several months ago, but the error is the same on all of them.

I cannot get to a terminal in the TemplateVM or the AppVM so I am at a bit of a loss for further troubleshooting. It looks like everything fails with a Snap.

Just a guess, but are they available to the relevant qubes and their templates? Did you try to increase their their storage in qube settings?

Yes, I had also tried increasing the Private storage max. size, and the System storage max. size by several GB. That did not change the problem or error output in the log.

There were some recent Kernel updates in Qubes. In the Settings | Advanced for the TemplateVM if I switch from the (new) default 5.13.6-1.fc25 kernel back to an earlier version 5.12.14-1.fc25 then things start working normally again.

If I leave the AppVM based on this template at 5.12.14-1.fc25, then it works as well.

It seems that this particular Debian 10 template is the only one that breaks with the newer kernel. This template has some Snaps and other software installed. Other Debian (full & minimal) and Fedora templates appear to be working.

1 Like