Dom0 update: Running transaction test Error

I tried to fix the issue with the Qubes Update following this


If I get it right I should just do this in dom0 to get it fixed:
qubes-dom0-update --clean -y
download works, dependencies resolved, installing and upgrading…
It works well until the final (y/N) - I confirmed with a y and the terminal returns:

Transaction Summary
Install   3 Packages
Upgrade  40 Packages

Total size: 229 M
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Error: Transaction test error:
  file /usr/lib/.build-id/10/426e215ebe20c87b885515b0c3a9b3284e0a68 from install of kernel-devel-1000:5.10.109-1.fc32.qubes.x86_64 conflicts with file from package kernel-devel-1000:5.10.96-1.fc32.qubes.x86_64

Seems to be some bug after upgrading 4.0 to 4.1:

After removing kernel-devel, the dom0 update was successful.

Well, neither the Qubes Updater nor the sudo qubes-dom0-update can fix it.

Try to remove the kernel-devel package and update again. In dom0 terminal:

sudo dnf remove kernel-devel
1 Like

This looks good now. Let me reboot and see if the Qubes Updater works now.

Rebooted all looks good now.
Just the Qube Updater took three inruns to get all templates updated.
Thanks @tzwcfq for your quick support!