Display problem since version 4.1

I have been using QubesOs since 2018 and no major worries.
6 months ago, I finally decided to install the 4.1 ! (although everything worked perfectly the 4.0)

Since then, it’s not so funny.
At the first startup, and once decrypted the disk but not yet opened the session, the screen flashes several times, as if the system was looking for the best display configuration, it stabilizes with scratches at the bottom of the screen, the mouse pointer, appears only when I move it.
I didn’t worry anymore and I thought that the next time I updated Dom0 or Xen or the Kernel, it would be fixed. Well no, it’s even worse! :neutral_face:
Since the end of June, blank screen. I took out an old external screen, it works, but the disk deciphering is done blindly.

Today, I finally decide to do some tests.
I’m going to look in the Bios if there is something that has moved? :thinking:
Nothing, but all of a sudden it lights up! :partying_face: I didn’t touch anything
I continue by booting on a LinuxMint live. Everything works, color screen, effect and everything. Here I am reassured because it is not a hardware problem ?
I thought that it was perhaps due to my processor which was a little soft, but while searching on the forum, I found other users with i7 of last generation, which have the same concern.

After my linuxMint test, I reboot on Qubes. I got my display back, but the colors are bland, I find. :face_holding_back_tears:

Here it is, it’s a feedback, if it can help the developers ?

Translated with www.DeepL.com/Translator (free version)

Perhaps it might be connected with the version of Linux in dom0. Which one is in Linux Mint, which in 4.1 and 4.0? Maybe you can try an older or newer kernel.

In linuxMint it is a 5.15.x kernel
Currently my Dom0 is using 5.15.x
I have a normal display only when I enter the BIOS!

@fepitre ici had also advised me to try the last kernel 5.18.x, but other user having the same problems since the passage to the 4.1 and having the problem also with the boot (no display of GRUB and the window to decrypt the disc) I did not try the kernel 5.18.x.
I think it’s a XEN problem ?
In any case, the i915 module is also guilty.

Following the update of Dom0, this day, always that on the external screen, I have now a nice Xen menu which is displayed before Grub, but which allows me to choose a different kernel. Cool !
I’ll try all this, and let you know what happens next.

Well, no luck, I’m offered two cores, but neither works! :confused:

1 Like

You’re not choosing right options while trying to load different kernel. I can’t remember precisely, but it was somehow after “Advanced…” in grub to enter parameters for chosen kernel then CTRL+R. Don’t hold me on this, but I’m sure everything is OK, just a proper procedure to load desired kernel.

This menu is before GRUB, it is a XEN menu and it appeared after the last Dom0 update. And I thought, wow cool, since I don’t have access to my GRUB anymore, since I don’t have any display at boot time, I’ll be able to try to boot on another kernel with this new menu. But no, it doesn’t work.

If this new menu does not allow booting to another kernel, can we hide it, as we can do with GRUB by setting TIME_OUT to 0?

4.14.5.config never works, and I believe this should be a documentation problem. Use 4.14.5 rather than 4.14.5.config.

In grub: Advanced → xen 4.14.5 → kernel 5.18.16. no command line is needed and you only need to make sure that you have the version of kernel installed