Problème d'affichage depuis la version 4.1

Bonjour,
J’utilise QubesOs depuis 2018 et aucun soucis majeur.
Il y a 6 mois, je me décide enfin à installer (bien que tout fonctionné parfaitement avec la 4.0 ) la 4.1 !

Depuis lors, c’est moins drôle.
Au premier démarrage, et une fois déchiffré le disque mais pas encore ouvert la session, l’écran clignote plusieurs fois, comme si le système chercher la meilleure config d’affichage, ça se stabilise avec des rayures en bas d’écran, le pointeur de la souris, n’apparaît qu’une fois que je la bouge.
Je ne me suis pas plus inquiété et je me suis dis qu’à la prochaine MAJ de Dom0 ou Xen ou du Kernel, ça serait corrigé. Eh ben Non, c’est même pire ! :neutral_face:
Depuis fin juin, écran blanc. J’ai ressorti un vieil écran externe, ça fonctionne, mais le déchiffrage du disque se fait à l’aveugle.

Aujourd’hui, je me décide enfin à faire quelques tests.
Je vais voir dans le Bios des fois qu’il y a un truc qui a bougé ? :thinking:
Rien, mais tout d’un coup ça s’allume !! :partying_face: j’ai rien touché
Je continue en bootant sur un live de LinuxMint. Tout fonctionne, écran couleur, effet et tout et tout. Me voila rassuré car à priori ce n’est pas un souci matériel ?
Je me suis dis que c’était peut-être dû à mon processeur qui était un peu mou, mais en cherchant sur le forum, j’ai trouvé d’autre utilisateur avec des i7 de dernière génération, qui ont le même soucis.

Après mon test linuxMint, je reboot sur Qubes. J’ai récupéré mon affichage, mais les couleurs sont fades, je trouve. c’est d’un triste. :face_holding_back_tears:

Voilou, c’est un retour d’expérience, si ça peut aider les développeurs ?
Si vous avez des solutions ? Au cas ou le problème réitère ?

Banzai

Est-ce que tu arrives à mettre à jour le dom0? As-tu aussi essayé d’installer dans le dom0 le paquet kernel-latest?

Bonjour,

Eh bien j’aurais dis oui, mais après vérification, j’en suis pas si sûr.
Je vous ai fait deux captures d’écran ça sera plus parlant.
(de nouveau ce matin en redémarrant j’ai perdu l’écran du laptop )


Comment je fais ça ?

Je pense que c’est à jour. Par défaut, seulement le dernier noyaux LTS (ici 5.15.X) est installé pour plus de stabilité. Lorsque l’on a du matériel récent il est intéressant d’installer le dernier noyaux stable (Actuellement 5.18.X il me semble). Les deux peuvent cohabiter sur la machine car on a fait en sorte de leur donner des noms différents. Pour tester, le dernier noyaux stable et voir si cela arrange les problèmes d’affichage, il faut dans le dom0:

$ sudo qubes-dom0-update kernel-latest

Ensuite redémarrer. Par défaut l’entrée amorcée par Grub sera le noyaux kernel-latest. Si cela venait à ne pas fonctionner (situation très rare mais sait-on jamais…), au redémarrage, il faut aller dans le menu “Advanced” de grub puis sélectionner la première entrée et là une liste de noyaux sera visible. Il suffit de sélectionner celle en 5.15.X pour démarrer normalement.

Je vais essayer, mais avant il faut que je remette le GRUB_TIMEOUT à 10, je l’avais mis à 0

Or ça ne prend pas. :thinking:
J’ai modifié en sudo sur dom0 /etc/default/grub
puis toujours en sudo grub2-mkconfig -o /boot/grub2/grub.cfg
C’est correcte ?
Ah moins que mon problème d’affichage soit aussi présent au boot et dans ce cas il faudrait que je connaisse avec certitude la manipulation pour l’effectuer à l’aveugle. Au cas ou… :see_no_evil:

La commande est bonne.

Bon après réflexion, je ne vais pas essayer avec le kernel 5.18.x. Car je ne pense pas que le problème vient du kernel.
J’avais déjà des soucis, pas aussi flagrant, à l’installation de la 4.1 avec un kernel 5.10.x
De plus, le live LinuxMint tourne sur un kernel 5.15.x et il y a aucun problème d’affichage.

Je pense que le problème vient d’ailleurs, de la nouvelle structure de la 4.1 ?
Car depuis cette nouvelle installation j’ai que des soucis, mineurs, mais par rapport à la 4.0, c’est le jour et la nuit.
Ou alors, c’est mon disque qui est mort et qui fait des erreurs d’écriture ?
J’ai aussi régulièrement des freeze des navigateurs web, que se soit sur Debian ou Fedora

LibreOffice qui me pompe toutes les ressources système !?
je viens de trouver une solution là : https://forum.qubes-os.org/t/100-cpu-with-every-scroll-in-libreoffice/8027

Pas moyen de redimensionner les fenêtres avec la souris !?
Et d’autre truc qui ne me vienne pas à l’esprit. Mais globalement la 4.1 c’est bof bof
Le seul truc flagrant qui à changé en mieux, c’est l’Open Qube Manager qui s’ouvre en 1 seconde contre 10s sur 4.0. Le bénéfice est maigre.

Dommage qu’il n’y est plus de support de la 4.0, sinon j’y retournerais sans hésiter.
Pardonnez-moi d’être un peu dur, c’est pas méchant, c’est juste un constat et tant que je peux je reste fidèle aux Qubes.

Et quoi qu’il en soit, merci pour votre temps et vos réponses, en français :smiley:
Si vous avez d’autre suggestion, je suis preneur !

Il ne faut pas oublier que Linux n’est pas le seul kernel a démarrer sur Qubes OS. Xen démarre avant et lance le dom0 avec le kernel linux. Il n’est pas inutile de tester…par expérience…

D’autre part, je ne comprends pas ce problème de Libreoffice. Je l’utilise très souvent sans aucune problème. Il démarre en petit (c’est un bug lié à libreoffice que nous avons déjà fait remonter et qui ne s’adapte pas au standard X11 il me semble pour certains évènements), et on peut le redimensionner sans problème.

Désolé que l’expérience ne soit pas bonne sur votre ordinateur mais contrairement à 4.0, cette version est beaucoup plus à jour et le moteur derrière gérant les VMs, QREXEC etc est beaucoup plus abouti. Personnellement j’utilise Qubes OS sur plusieurs serveurs avec des générations différentes de 2011 à 2021, différents postes bureautiques ou portables. Il arrive parfois d’avoir des soucis gênant d’affichage par exemple mais généralement les mises à jour kernel suffisent à en résoudre la plupart.

Oui, je suis d’accord. Si j’arrive à afficher de nouveau mon GRUB au démarrage, je ferrais le test.

Moi non plus, je ne comprend pas pourquoi il me prends 90% des ressources cpu.
Plus de problème d’affichage depuis la 4.1, ça s’ouvre en plein écran. Top
Les problèmes de re-dimension des fenêtres touche essentiellement “Fichiers 3.38.x” sur Debian et “Fichiers 41.5” sur Fedora. Pas de soucis pour les différents programmes (libreoffice, audacity, digikam, calibre…)

Oui, je n’en doute pas. Mais effectivement pour moi et ma bécane on galère un peu.

J’ai redémarré et mes 10 secondes sont bien là, mais pas d’affichage du GRUB. Alors le problème ne viendrai-t-il pas de Xen ?

j’ai trouvé ça, mais je ne suis pas sur de bien comprendre le déroulement des manipulations et si ça peut régler mon problème.

On avance. le problème serait le GPU d’intel
https://wiki.archlinux.org/title/Intel_graphics

Et l’absence de réponse dans Chromium et Firefox y est aussi connu ! Incroyable !!

Reste à savoir quel option à modifier ou créer pour régler tout ces problèmes.

Je me demande si mon problème de batterie qui ne charge plus, ne serais pas lié itou ?

Xen ne démarre pas avant/pendant le Grub.

j’ai essayé cette méthode

mais ça ne change rien pour moi. En même temps, cette méthode est pour corriger un scintillement, alors que pour moi, j’ai un écran qui ressemble à un “Patchwork” très sombre au boot et qui vire au blanc.

J’ai essayé avec l’option fbc=1

je récupère l’image quand je bouge la souris, mais la perd tout doucement si aucune activité.

Petit reportage photo pour mieux comprendre la problématique.

Boot mdp bios

Déchivrage du disk à l’aveugle

Mdp login

Login

Avec l’option i915 enable_fbc=1, quand je bouge la souris je récupère l’écran.

Alors c’est mieux avec fbc=1 mais c’est loin d’être parfait.
Je continue mes investigations… :smiley:

ce matin, j’ai de nouveau perdu l’écran du laptop :unamused:

Hello,
Bon en fin de compte c’est un problème matériel !! :roll_eyes:

En rabattant mon écran, l’image est réapparu. :face_with_raised_eyebrow:
Dorénavant, il faut que j’appuie régulièrement au dos de l’écran pour que je puisse avoir une belle image. Donc Qubes Os 4.1 est au top :heart_eyes:

Mille excuses pour le dérangement.

1 Like