Dell E6430 i7

I have just tried, in every which way, to install the latest qubes on this Dell without success. I will say that I have had qubes on this machine a few times in the past and with 16gb of RAM it has worked faultlessly. This latest version will install to the point where it reboots and gets near the end where it is configuring networks and it freezes. I have tried uefi and legacy but the result is the same. In the end I gave up.

Notwithstanding the great and valuable work done by the developers and maintainers of QUBES this latest version gives me grief every day. The not starting of sys-usb is sending me mental and this problem appears to be get getting more frequent and is now requiring reboots, sometimes more than one which is going to relegate qubes to being a curio that I use occasionally rather than as my daily which is not what the project wants I’m sure.

But I digress. Not being able to install it on this Dell is another irritation. I have the E6430 and a E6530 and both have run qubes brilliantly so this latest version is actually a regression. I did install it on my E6530 which is not where I wanted it, but it works.

If I come across as whingy I apologise, but the reality is that things like hours spent trying to install as outlined above, having to reboot this machine twice this morning to get sys-usb going is making qubes a system with overhead that I don’t have the luxury of accommodating. I hope that this sys-usb issue is fixable. The previous version of qubes was insanely stable on my Dells and two Lenovos. Just sayin’.

(Seems down right now…)

Also, you could have a look at the HCL and find similar hardware there, check the notes if any.

@fepitre reported that it’s down for now:

But you can use builds from

Did you add no strict reset option to your USB controllers in sys-usb?
How to add this option:

1 Like

Thanks for getting back to me. I will take the Kernel advice, but for now I’ve spent hours and hours on qubes this week and I’m qubes’d out.

The E6430 is listed as being compatible and I’ve proved it to myself over and over. I had two of them at one point, both running qubes seamlessly. I

I’m actually in the process of purchasing either a Purism V14 or a Framework laptop as a major investment (for me at least) and having a laptop with new components. I’m not sure which way to jump just yet.

No, I haven’t tried the no strict reset option. I’ve just had a quick look…is that in qubes settings?

You can add it in Qubes Settings:

You can also configure strict reset directly from the Qubes interface by following these steps:

  1. Go to the sys-usb VM settings

  2. Go to Devices

  3. Make sure the device is in the right field

  4. Click “Configure strict reset for PCI devices”

  5. Select the device, click OK and apply

1 Like

Very cool. Thanks.

I just had a quick look and there are three devices in the right column by default. Do I just leave all three of them there and click strict reset, or do I have to selectively remove any of them?

With the run I’ve had with qubes this week I don’t want to break anything.

Only one of them is in the list of Community-recommended computers.

The other one is discussed here: one, two, three.

Thanks for the framework links. I had seen one of them, not the others. I am very much across the Purism as I frequent the Purism forums (you too, I assume by your handle…).

Are you able to advise about my query above with the devices listed before I do a strict reset? Sorry to pester, but, as I said, I don’t want to break anything :slight_smile:

1 Like

Yes, disabling strict reset should allow sys-usb to startup correctly. Every device which does not behave well without it, should have it enabled. You probably have several USB controllers, if you have multiple devices. This is a useful thing.

Lovely, thanks. I’ll attack it later today.