Dark Theme for [Qubes Manager] Not Working in 4.1

I applied @fepitre’s export, thus got the third style applied when run from terminal. But, long ago I had the other two styles when run from Qui-domains and app menu and never set any platfortheme manually that I’m aware of (I don’t even know where those places could be). Same for Qube Settings window
But, how’s that possible in the first place?

@enmus asked wrote:

But, how’s that possible in the first place?

It probably has to do with the place where you exported QT_QPA_PLATFORMTHEME, more precisely whether it would be in the environment when the respective application gets started.

To illustrate that you can play with this in a dom0 terminal:

[user@dom0 ~] QT_QPA_PLATFORMTHEME=fusion qubes-qube-manager
[user@dom0 ~] QT_QPA_PLATFORMTHEME=gtk2 qubes-qube-manager

In this cases you are explicitly setting the environment variable for the particular launch. If instead of fusion or gtk2 you used qt5ct it would pick up whatever theme you configured in the respective configuration app.

That’s the main reason I set this variable in /etc/environment and only there, to make sure it is exported and available in all contexts.

Thanks for the tips. I tried them all (setting in enviroment too) and they all impact only terminal-started Qube manager. Qube managers started from Qui domains as well as from app menu are immune to this.

How’s that possible?

And as I wrote, even those two differs from each other (it looks like Qui-domains’ ran Qube manager doesn’t follow font size set in System Tools → Appearance?!

@enmus did you reboot your computer after making those changes?

@Sven thanks for the support here. My Qubes has been getting more eyes-friendly now :sunglasses:

Hint: For Firefox, I added the “Dark Reader” Add-on.

Of course I didn’t! Otherwise, I’d assure myself everything was OK now, and my previous post wouldn’t exist. Thanks and apologize.

So in conclusion. Only way to make Dark Mode work is installing qt5-qtstyleplugins in dom0?

If you want Qt5 apps to use the same (dark) theme you set in XFCE: yes. Otherwise you could also install other Qt5 dark themes and apply those. But in any case you will be installing packages.

Hence I have already filed an enhancement request which will be evaluated by the project team. They will choose whatever method is best, but this is the only one I am aware of.


I installed it and add export to /etc/environment, but still taskbar and boarders of all dom0 windows are silver.

Those are not Qt5, so the changes you made cannot affect them. This thread was about Qubes Qube Manager.

The borders of dom0 windows are based on the theme you selected under “Style” in “Window Manager” (see XFCE settings app). You’ll have to go through them to find one that suits you.

The taskbar will reflect whatever theme you have selected under “Style” in “Appearance” (see XFCE settings app), however I too have observed that not all of the themes you can select there work flawlessly with the taskbar.

These work (as far as dark themes are concerned):

  • Adwaita-dark
  • Arc-Dark
  • Arc-Dark-solid
  • Greybird-dark
  • Xfce-dusk

These don’t:

  • Arc-Darker
  • Arc-Darker-solid

Personally I am a fan of the Ubuntu esthetics so I elected to import the Yaru themes, icons and the Ubuntu font to dom0. Yaru-dark works flawlessly too.

1 Like

Thanks again. I found the window settings in the meantime but can’t make taskbar work. Right side with icons is dark but everything else not for any theme.

You might need to logout and log back in to have it refresh.

1 Like

I’m not sure if it’s related but I had this problem after I did a Qubes installation without the Fedora, Debian and Whonix templates and any sample AppVM pre-installed.

Edit: I guess it’s not related to this.

Strange. This worked after multiple reboots but it suddenly didn’t work after a random reboot. I had Appearance as, Adwaita-dark and Windows Manager as Arc-Darker. But when I disconnected the power, the theme reverted to default.

Then I selected a known working Appearance, Xfce-dusk and Window Manager Arc-Dark and rebooted and got it to work. From there, I switched Appearance back to Adwaita-dark but left Windows Manager at Arc-Dark. But this doesn’t persist after a reboot. Seem like repeating this is the work-around for now.

Yeah, none of the procedures outlined in this (and other) threads have actually worked for me. Qubes Manager is still default despite repeatedly setting Arc-… or Adwaita… schemes. Might be something to do with me being on i3 but all the other XFCE display settings persist in other apps. What is it about the Qubes Manager that defies these settings…?

And you also tried

Multiple times, multiple themes, same result, as I said.

Did this: https://github.com/QubesOS/qubes-issues/issues/7389#issuecomment-1206163711
and then it worked.

Thanks for the info. As suspected the i3 window manager does interfere here. I already had a
~/.cache/sessions/xfce4-session-dom0:0 file, so I ran xfsettingsd anyway. It errors out as it is unable to find an XFCE session. So I logged out, then logged back in using an XFCE session and boom! Qubes Manager has the dark theme!

Unfortunately when I log back in to i3, it all goes back to normal: no dark theme applied to Qubes Manager… (sigh)

I wonder if having the panel / taskbar hidden has anything to do with it. I normally have them hidden. I unhid them, selected Adwaita-Dark, rebooted and they’re now dark. I haven’t rebooted since then to see if it persists.