Crashed system; Qubes OS doesn't log-in; these are the screen logs

I installed Qubes OS on a Lenovo Thinkpad. The SD card and the DVD drive were not connected to sys-usb. I connected the SD Card via sys-usb > Qube Settings > Devices. It worked. Then I tried to locate the DVD drive and couldn’t. I connected the only SATA entry under PCI devices, making a guess that it was the DVD drive. And my system crashed within a few seconds. I rebooted several times. This is what I got after I put the LUKS password.

That was it. Even CTRL+ALT+DEL did not reboot the system. I had to press the power button for several seconds to shutdown the system. I’m surprised how easy it was to kill the whole system.
Would anyone be able to identify the problem and suggest a fix? Is there hope to salvage my machine?

This may be my problem…

Well, I solved the problem after reading this:

I booted the system in TAILS.
Found the Dom0 partition as per the instructions here: How to mount a Qubes partition from another OS | Qubes OS
Found /var/lib/Qubes/qubes.xml in Dom0.
Ran in TAILS lspci and found that SATA is: id="00_1f.2
Found the line that had 00_1f.2, and that was under sys-usb.
I deleted that line.
Rebooted the system.
It worked.

1 Like