Corrupted Template


I installed a .deb recently and it wouldn’t launch due to insufficient memory. I rebooted the qube (templateVM) but now it will not properly launch. The VM shows as being started, but the terminal will not come up on the screen.

Thank you

Hi. You could increase the system storage memory in the Template VM’s Qubes Settings from 10240 MiB to something like 15000 MiB, as well as increasing the private storage, to see if this addresses your problem.

1 Like

Hi there

I’ve already tried this; changing the hard drive and memory capacities. There is nothing returned from the Qube to give any hint as to what the issue is. The qube starts but none of the apps open. The logs aren’t terribly informative either.

Thank you


The issue is better described here Qube Starts but Applications will not Run · Issue #5751 · QubesOS/qubes-issues · GitHub. tried opening a terminal using qvm-run but nothing launches. Also, the verbosity doesn’t give any more detail.

Thank you

If you haven’t restarted it yet, you may still be able to revert it to a point before the installation of the deb that broke your system.


Thank you for this. Is there cli command or RPC to uninstall a package? Or could I SSH into a Qube from dom0 somehow?

Thank you


I checked for any any available backups using

qvm-volume info vmname: private

unfortunately there are no available revisions for revert.

Trying to find an RPC call from the ones available in this directory:


Thank you

Hoping to find an RPC call from the list of available:


thank you

If you are not able to roll back the system as suggested, then you can
start the template and connect to it using sudo xl console .. in dom0
Log in as root and you should be able to identify the Qubes packages you
removed - this is almost certainly the problem.
When you have finished, Ctrl+] will close the session.

Ok sounds good

so it’s “sudo xl console [ID]” right ?

I didn’t remove any qubes packages but I did install a .deb file

so it’s “sudo xl console [ID]” right ?


Depending on what the deb file was, it’s very easy to have qubes
components removed if you are not careful. It happens all the time, and
the symptoms exactly match your case.

Which Qubes components are you referring to and why would the installation of a .deb (assuming its not malicious -> it could be) affect Qubes components. Do you mean they would be uninstalled or overwritten?

Debian packages for a complex web - so installing one package can pull
in with it many dependencies. Some of those other packages may remove
packages that are dependencies of Qubes packages.
This is why package installation generally shows you exactly what is
going to happen.

But instead of talking in hypotheticals, lets be concrete:
What was the package you installed, if you care to say?
If you examine the apt and dpkg logs, do you see any Qubes packages
being removed?

1 Like

Ok I was able to login to the Qube but when I attempt to open the log file in /var/log/ the file is full of gibberish characters (it looks like wingdings) and whenever you use the backspace character, it prints it to the screen instead of just applying the backspace. Tried to use “cat” to view the log as well as the text editor vi

If you want help you have to give a little - you haven’t said what the
deb package was, how you installed it, you haven’t said what “the log”
was - it’s so much easier if you give precise details.

So -
I installed package foobar in a standard debian-10 template after
downloading it from, using this command:
sudo dpkg -i foobar.deb
Since then I cannot open programs in qubes using the template, although
the qubes appear to start and stop properly.

I accessed the template using sudo xl console <template>, but the
contents of the file /var/log/apt/history.1.gz were unreadable using

Do you see how helpful that is?

In the template, run dpkg-query -l |grep qubes - you should see

If you don’t have these, try to install them using apt, and look to see what
conflicts you encounter.
(You may see other qubes packages, but focus on these.)


Yes as was stated in my previous posts. All of the packages you mentioned are present

What was the deb package?

it was for the bisq desktop app

And did you follow these steps ?