Configure network access

Hi to all,
after successfully installation of Qubes 4.2 i do not have network (internet) access. How to configure network access manually to be able e.g. to update the installation.

Best regards,
Bapak Hitam

hey hitam,

what do you mean by “i do not have network (internet) access”?
Go to Qubes Manager and check if sys-net is on (green dot on the right side). Do you see the “2 red displays” icon on the bar near the clock? There are a lot or questions I can ask…but give us the minimum of details.

Do you have a (red) network symbol in the task bar? It’s the one from sys-net and there you can (with right click and configure settings) edit the network settings manually (IP: 192.168.XXX.XXX // Subnet: // Gateway: 192.168.XXX.1) - so they point to your router…

1 Like

Sorry for the lack of detailed information.
this is was the Qube manger shows me, after i open it.

here is another image from the screen:

No Network (WIFI or LAN) devices available.

Did you get any errors during the installation process?
What you see there is just the dom0 (which is the Xen Hypervisor main container). You don’t have any AppVM there including the sys-net which handles the network.

You should have seen something like this:

This looks like the “INITIAL SETUP” didn’t run at your first boot from the new installation.

Can you open a terminal and run:

sudo /usr/libexec/initial-setup/initial-setup-graphical




Thanks Chris… Assume this will be the solution! But wonder if he’ll get any errors while running this…

Hi, thanks for your kind reply.
I cannot remember any problems during setup.
Before i use the UBUNTU installer with does have an explicit network option.

The “INITIAL SETUP” is usually rather kind and dumps errors on the terminal (as to why it can’t run). Those errors can be used for further debugging … the automatic run at first boot just fails and hides the error somewhere … and the first times around, I didn’t know what to look for/expect and notice what was missing …


Maybe the title of the topic should be renamed to something like “No qubes after fresh install” or “error during initial setup” so others with the same problem can find it more easily

these are the error messages and the terminal output from the graphical installation process:

Regards, Bapak Hitam

lets see what the experienced guys say, but my suggestion would be to choose the option “Use existing LVM thin pool” in the first screenshot

Good luck :slight_smile:

Ok, thanks for your feedback.
What is this option all about anyhow ??

I am definitely no expert with anything regarding pools, but I interpret the error message as: “You have this already from your last install and I don’t want to create it again”.

Therefore, my fix would be to say: “Alright, take the one you already created.” (the existing one)

Actually, I would reinstall the whole thing, but that might be too paranoid :wink:

Also had a reinstall with my first install…

actually, I forgot: just reinstalling probably has a high risk of running into the same error again, so finding the source might be a way better choice…?


Once the source is know, I would personally do a clean install (also “I wonder if that happens every time”) … but for the debugging, it makes sense to first “Use the existing LVM thin pool”. :slight_smile:

I’ve had issues with QUBES OS on a MacBook, where the “INITIAL SETUP” would die (due to spaces in the anaconda.ks) and the Qubes fail to start (unless I selected BTRFS at install) and the network card needed some special setting - that took several reinstalls to get right …


1 Like

[quote=“ChrisA, post:18, topic:25349”]

I selected the option
“Use the existing LVM thin pool”
and the setup ran into this error message:

the Qube Manager showed me the following:


In setting i did not find any possibility to configure the IP Address (I use fixed addresses)

After selecting the Kill Option: i received the following error message:

What is for me to do next ?

Could you try to run the following in a dom0 terminal:

cat /sys/block/nv*/queue/hw_sector_size
cat /sys/block/sd*/queue/hw_sector_size



1 Like