Changing brighness via shortcut fails to change screen brighness

I just bought a laptop from TUXEDO Computers and installed Qubes OS on it. (This is also my first time using Qubes OS.)

Problem: Xfce(?) recognises the [fn+F8] and [fn+F9] key strokes as the correct key strokes for brightness adjustment: It displays the brightness label and the current brightness bar next to it in a notification. However the actual screen brightness is not adjusted. The screen always has the same amount of uncomfortable brightness even after a reboot. Also one weird thing happens: each time I press [fn+F8] or [fn+F9] a new instance of the “[Dom0] Display” appears.

Attempts to fix the problem:
I searched this forum and the internet, but could not find anything suitable to my specific device. I tried different things, e. g. switching to KDE as suggested in one place, but had no success.
On the webpage of TUXEDO Computers there are instructions for fixing issues with non functional adjustment of screen brightness: https://www.tuxedocomputers.com/en/Infos/Help-Support/Instructions/Brightness-for-120-Hz-and-144-Hz-displays_1.tuxedo
The fix works on systems with grub and is applied by editing /etc/default/grub and adding device specific parameters to the grub command line. However I do not know if this can be applied to the different infrastructure of the Qubes OS Dom0 system.

Questions: Does anyone know from my descripton of symptoms what the problem could be and how it could be solved? Or does anyone know a way to apply the suggested fix on the web page of TUXEDO computers to the Dom0 system?

1 Like

Sometimes I adjust the brightness manually via the following command on a dom0 terminal:

[user@dom0 ~]$ sudo -i
[root@dom0 ~]# echo 120 > /sys/class/backlight/intel_backlight/brightness 

Command explanation: for those who are not aware, linux follows the idea that everything is a file. So the current brightness is a file just like any other. Basically what I’m doing there is writing a brighness level to that file. It should immediately change brightness.

If that does anything in you case, I’d say its a good sign because Qubes is able to change your screen brightness and it must be a problem perhaps with XFCE.

But I can’t really help much more than this.

(Changed the title to make it a bit more concise. Feel free to tweak it if not adequate)

1 Like

Thank you for this suggestion. It helps analyse the problem somewhat more. And the changed title makes sense.

I executed your command adapted to my hardware:

echo 10 > /sys/class/backlight/acpi_video0/brightness

(10 instead of 120 since cat /sys/class/backlight/acpi_video0/max_brightness outputs 49)
and the “[Dom0] Display” window popped up again, but the brightness remained unchanged (no matter which number in the valid range is written). The command seems to change some display parameter which is recognised by the system because it displays the “[Dom0] Display” window. The file interface /sys/class/backlight/acpi_video0/max_brightness does not seem to be correctly connected to the actual hardware address which controls the backlight.
The brightness bar notification did not appear, I guess due to this command completely bypassing Xfce and Xfce not listening to changes in /sys/class/backlight/intel_backlight/brightness.
The value of /sys/class/backlight/intel_backlight/brightness really changes after writing different numbers, so there is no problem writing to this file. It also changes when I press [fn+F8/F9]. I conclude that it is not Xfce's fault.

I know that changing the brightness can work because I tested a fedora live system today and with it I was able to control the actual display’s brightness using [fn+F8/F9] without any preparations on my part.

In my original post I mentioned the instructions on the manufacturer’s website. I summarise them here:

  • sudo nano /etc/default/grub,
  • add the parameters acpi_osi= acpi_os_name=Linux i915.enable_dpcd_backlight to the variable GRUB_CMDLINE_LINUX_DEFAULT,
  • update grub and reboot.

I was not able to see how to apply this to Qubes OS, since the boot architecture looks different, e. g. the file /etc/default/grub does not exist. Does anyone know a place in which the above mentioned parameters and/or their values can be placed in order to tell the system how to use the backlight correctly?

1 Like

Nice debugging writeup. Now we know pretty much were the issue lies.

If you can’t find this by searching, my suggestion would be to open a reply as linked topic:

  • top left square on the reply editor » + reply as linked topic.

That will make it easier for others to find the specific sub-problem and potentially help.

Tank you for this suggestion. I just did that.

1 Like

I meant more about the following remark. (sorry about the confusion)

But I guess the one you posted is also ok.

This makes sense. I took out repetitive parts and added this detail.

1 Like

The solution was found on this other thread: