GPU driver necessary for functional backlight control?

On my laptop (TUXEDO Aura 15 laptop, cat /proc/cpuinfo => AMD Ryzen 4500U with (integrated) Radeon Graphics) with Qubes OS the backlight control does not work (backlight always uncomfortably bright). In short pressing the dedicated brightness key strokes [fn+F8/F9] changes the value in /sys/class/backlight/acpi_video0/brightness, but it does not affect the brightness of my screen (instead just opens the “[Dom0] Display” configuration window). (A more comprehensive analysis of the symptoms has been discussed here: Changing brighness via shortcut fails to change screen brighness)

On a Ubuntu Live System running on my laptop the brightness control works, but in Ubuntu I find the directory /sys/class/backlight/amdgpu_bl0 instead of /sys/class/backlight/acpi_video0/brightness in Qubes OS. I guess the difference is that Ubuntu has the appropriate GPU driver at hand. However, I am not an expert.

My questions are:

  • What is the difference between /sys/class/backlight/amdgpu_bl0 and /sys/class/backlight/acpi_video0/brightness? Is it that Ubuntu uses the appropriate GPU driver?
    • If yes, does that mean that the appropriate GPU driver is a prerequisite that brightness control can work on my laptop?
    • If yes or no, does this indicate a way to fix or enable brightness control on my laptop by another way than through the GPU driver? (I would prefer that for security reasons.)

Hi @chrfre,

did you already find a solution for setting the brightness?
I am using a TUXEDO Pulse 14 (AMD Ryzen 7 4800H, Radeon RX Vega, integrated graphics).
I also tried to set brightness using echo 12 | sudo tee /sys/class/backlight/acpi_video0/brightnes in dom0-Terminal which had no effect.

Using a Lubuntu live distro it worked flawlessly.

I also used Xfce Power Manager to set the “Handle display brightness keys” to “on” in the General tab => no effect at all.

Display is running full brightness killing my eyes.

One further issue: using an external monitor using the HDMI port does not work with this setup. I created a separate thread for that: HDMI: external monitor is not detected

Hello @devnull, just recently I came across this post: which is why I have resigned to waiting for a regular dom0 kernel update to 5.8 or newer.

WARNING: Actually I also tried a newer kernel from the latest repository, but this left my system failing at boot and I needed quiet some time to recover it - perhaps due to my lack of experience.

Maybe a newer kernel could also fix your issues with similar hardware.

1 Like