Can't update

This is the error I get when trying to update (none of the updates, Fedora or Debian, succeed, and it seems like a general internet proxy error):

Updating fedora-33

Error on updating fedora-33: Command ‘[‘sudo’, ‘qubesctl’, ‘–skip-dom0’, ‘–targets=fedora-33’, ‘–show-output’, ‘state.sls’, ‘update.qubes-vm’]’ returned non-zero exit status 20

        ID: /usr/lib/rpm/macros.d/macros.qubes
  Function: file.managed
    Result: True
   Comment: File /usr/lib/rpm/macros.d/macros.qubes is in the correct state
   Started: 07:44:12.190060
  Duration: 57.508 ms

        ID: dnf-makecache
  Function: cmd.script
    Result: False
   Comment: Could not create DNF metadata cache
   Started: 07:44:12.341574
  Duration: 5421.316 ms

        ID: update
  Function: pkg.uptodate
    Result: False
   Comment: One or more requisite failed: update.qubes-vm.dnf-makecache
   Started: 07:44:23.989928
  Duration: 0.014 ms

        ID: notify-updates
      Name: /usr/lib/qubes/upgrades-status-notify
    Result: False
   Comment: Command "/usr/lib/qubes/upgrades-status-notify" run
   Started: 07:44:23.990119
  Duration: 9916.293 ms
                Error: Failed to download metadata for repo 'updates': Cannot prepare internal mirrorlist: Curl error (56): Failure when receiving data from the peer for [Proxy CONNECT aborted]

Summary for fedora-33

Succeeded: 1 (changed=1)
Failed: 3

Total states run: 4
Total run time: 15.395 s

I assume the most important part from that is “Proxy CONNECT aborted”? I had similar issues with my Debian templates, and the most relevant part from that seems to be:

Reading from proxy failed - read (11: Resource temporarily unavailable) [IP: 8082]

Teach me to fish

If possible (and if the answer isn’t a simple, “oh, we know about that and will fix it soon”), can you tell me how to troubleshoot these proxy errors? Here’s what is already in my arsenal, please add more tools to it:

  1. I looked up the qubes.UpdatesProxy since someone previously helped me find that file. (whonix updates succeeded just now after fixing the vm name in that file). The other entry still says:
    $type:TemplateVM $default allow,target=sysFirewall
  2. I ran a ping in sysFirewall before running the updater, and the ping succeeded.
  3. I tried restarting the relevant Qubes, to no avail.

I can’t provide a deep technical explanation, but I often see similar errors when updating. I’ve found that simply trying again, or restarting the template, waiting a while, then trying again usually does the trick for most of these types of errors.

Seconded - it’s a download failure, probably transitory.

@adw @unman: It was not transitory, but I did find out something interesting: using sysWhonix as the update proxy works, but even after updating that way, subsequent updates still do not work through sysFirewall.

I’d still like to know what went wrong, and maybe make updates quicker since sysWhonix is really slow.

This still needs a solution, and it is getting more urgent because my Whonix (my only way to update) is reaching EOL very soon! See Testing whonix-ws-16 and whonix-gw-16