Can't get the QubesOS-contrib qubes-tunnel to work in 4.1?

I was able to install the contrib repo and qubes-tunnel without any errors but when I try to use the sys-vpn I get nothing. I am not able to ping any IPs from within the sys-vpn and other appvms arent able to use it as a proxyvm.

I ran journalctl -u qubes-tunnel as suggested by @tasket in another post and posted it here.

I admittedly cant make much sense of the output though the reoccurring error in the output was qubes-tunnel.service: failed with result “exist-code” and “failed to start Tunnel service for Qubes proxyVM”

AFAIK I followed the instructions to the letter, though I seem to have rotten luck with VPN proxies so would not rule out having done a step incorrectly (though I have retried multiple times).

Thought/advice would be appreciated!

PS for what its worth I am using a debian-11-minimal template and have RC3 installed

qubes-tunnel is the older version, try GitHub - tasket/Qubes-vpn-support: VPN configuration in Qubes OS

B

Really? Its kind of hard to tell, on the docs page it references one way, the @fepitre quobesos-contrib qtunnel another way, and @tasket vpn yet another way.
and when I look at commits it seems fepitre’s last commit was Oct 9th 2021 and tasket’s Oct 20th 2021? (not that I really understand git commits), and states “Qubes-vpn-support is tested to run on Fedora 30, Debian 9 and 10 template-based VMs under Qubes OS 4.0.1”…

I think I had tried taskets quite awhile ago but wasnt able to get it to work (this was years, so I am sure its changed), then was able to get the method covered in the Qubes docs to work so stuck with that for a few years, then saw the qtunnel version which was the easiest to set up… if I could get it to work.

I guess I am just a bit frusterated by how difficult it still is to get a vpn proxy set up, and how unclear it is which method I should use.

Thanks for the link, I will give tasket’s a try again as its been a few years - I guess if I cant get that to work I will go back to the method covered in the docs.

The way I would recommend is to use qubes-tunnel from our contrib repository. I use it under bullseye with multiple VPN providers without any issue. I invite you to give it a try following GitHub - QubesOS-contrib/qubes-tunnel: Integration of vpn tunnels for Qubes OS.

Thanks for the response.
I certainly prefer the qubes-tunnel as I found it to be much easier to setup, the caveat is that I havent been able to get it working.
I posted the journalctl -u qubes-tunnel output on debian’s pastebin but it wasnt clear to me how to address the errors?

In the log I see: notify-send: command not found I’ve not checked into details if that would block VPN to start. Can you try to install it to see if it works? If this is the case, something needs to be patched. Else, I will try to take another look.

I tried doing
sudo apt-get install notify-send
and it doesnt seem to be a package, tried sudo apt search notify-send and a ruby package was the only thing, I installed it anyway but nada, the vpn vm still apears to not be working.
I am not sure if it was needed but I installed qubes-core-agent-networking qubes-core-agent-network-manager as well but still not working?

Try libnotify-bin

Ah thanks.
Tried it, seems its already installed (v0.7.9-3)

ok so what about logs now if you restart qubes-tunnel?

Well, now it works?
https://paste.debian.net/hidden/ea9c5546

I have no idea why, the only thing i installed since posting was the ruby-notify thing, everything else was already installed according to apt?

I guess this is a case of it doesnt work until you ask someone then it works LOL

I will try reinstalling from scratch again as I really want to be able to get this working solidly - without having to bug the forum for support.

Thank you

Ignore the ruby notify thing and simply install libnotify-bin as suggested. I’ll try to fix the debian control file.

Ok, I missed that qubes-tunnel is now the king. Noted.

B

Minimal templates is for advanced user, mean that you need to know required package to run app, if you use regular template it’ll work out of the box as example my guide here

Thanks for the link.
As for advanced user or not, I dont consider myself advanced but have used the fedora and centos7 minimal templates for a few years, the problems I have had usually ended up being configuration related not so much not having the right packages installed. One of the reasons I wanted to try the debian template was its more LTS than Fedora and isnt slated to be discontinued like centos7.
Will take a look over the guide, might be some useful tricks in there :slight_smile:
Cheers

Thanks! still unsure what changed as it indicated that libnotify-bin was already installed and up to date, regardless the support is appreciated!

1 Like