Cannot create sys-usb via salt

So I just got my new server late yesterday and I am almost done with all updates and such.
But for some reason I can not create a “sys-usb”, why?

sudo qubesctl state.sls qvm.usb-keyboard

So all my USB’s are dumped into dom0…

Installing sys-usb is periodic time for anyone. In order to fully install sys-usb, delete the sys-usb then reinstall it at daytime. This way, it can install it properly. If this happens again, then you need to reconfigure your server to allow that happen. Why? Installing sys-usb might need go out to the internet to the server for the scripts. Otherwise, I will tag @unman, @deeplow, or @Sven for that troubleshoot.

It was never created as far as I can see. It doesn’t list anywhere.

read this

So I do what you sent me to follow even added the 2 lines in the files for mouse and keyboard.
Now I have NO MOUSE OR KEYBOARD, can’t login.
So I attached PS/2 mouse and keyboard logged in still NO MOUSE OR KEYBOARD and USB’s still connected to dom0…
I really have nothing nice to say here, unbelievable!!
Never had any problems with 4.0.x

Yep

Adding those lines did nothing for my USB mouse & keyboard. They didn’t even work. Slaved out PS/2 mouse & keyboard to login and then delete this “sys-usb”. Also it showed up as a regular app domain not like the other ones…
service: sys-firewall
service: sys-net
service: sys-whonix

I am just mad my friend, can’t believe I am having this problem…
SO I deleted this “sys-usb” as it isn’t working. All my USB drives are back in dom0 and back using my USB mouse & keyboard.

I hope they get this fixed soon OR I will just remove all USB hard drives and stick with what I only have.

Let me tell you this. The ways of getting the sys-usb domain working are to add in the sys-usb manually and start up that thing.

In /etc/qubes-rpc/policy/qubes.InputKeyboard of dom0 terminal:

sys-usb dom0 ask,default_target=dom0
$anyvm $anyvm deny

That way you can have usb keyboard with you.

In /etc/qubes-rpc/policy/qubes.InputMouse of dom0 terminal:

sys-usb dom0 ask,user=root,default_target=dom0
$anyvm $anyvm deny

This will be enable your usb mouse

In /etc/qubes-rpc/policy/qubes.InputTablet of dom0 terminal:

sys-usb dom0 allow,user=root
sys-usb dom0 ask,target=dom0
$anyvm $anyvm deny

This will turn on the touch screen feature that everyone annoys about.

After that, restart the whole computer with sys-usb auto start enable. There, they just ask you to have them—just press the ENTER key.

I think you should install Qubes with sys-usb enabled while all usb devices detached. Also, you have to know how many controllers you have, and to which controller your keyboard and mouse are attached and to assign that controller, if possible, to a correspondent usb qube. But it looks you have PS/2 ports, so I’d have no dillema - I would never use usb keyboard and mouse.

@HPOA909 don’t know why I can’t get sys-usb to work…maybe it’s because this is a newer server.

@enmus …well yes I agree BUT all USB hard drives are now in dom0, even my USB sticks when I jack them in to a USB port go right to dom0 and that’s a HUGE issue…

Qubes does not works on server. If you install that to the server, the sys-usb does not works.

@HPOA909 it’s a workstation that can be used/setup as a server. The option is there if a user so inclined to use it that way.

Also sys-usb for 4.1 wasn’t work either on my (hp z420) which is found on the HCL.

@enmus I have 3 USB controllers found in this beast…USB 2.0 & 3.0

Which leads me to these questions…

  • there is a problem with this newer version of qubes 4.1 sys-usb. I can’t create it in dom0, I can’t create it manually either.

  • qubes doesn’t support my chipset, which is C612

  • qubes doesn’t support (2…12core processors)

  • qubes has a problem supporting Haswell v3

But I will say qubes os runs very very smooth and fast on this animal. Does not miss a beat.
Just this sys-usb issue…

Emailing Sven to add to HCL all the details on this

If I were you I’d make clean new install with sys-usb selected during install especially dom0 is already exposed to usb devices now, which should be considered as compromising dom0. Is that possible for you? After that I’d clone sys-usb to 2 more clones and would assign each controller to a single sys-usb. Do not use any usb device during install.
Anything beside that would leave space for more and more misconfigurations.

@enmus I am not reinstalling this a 3 time. I have already built out most of my templates and domains. There has got to be a better way…

If they can’t fix this then o’well I move on with what I have then

You can always backup templates and later restore them, but I understand you. I’m not sure that there is something to be fixed though, that;s why I suggested clean install with sys-usb enabled.

It would be such a shame such a beast not to get polished install.

It already had a polished install on 3 new SSD’s…

And I just installed humans parrot template and I can’t update again asking for password in terminal… I am also using your cmd in terminal you gave me…

qvm-run --pass-io -u root “apt install --no-recommends qubes-core-agent-passwordless-root -y”

Not working

Parrot is fixed now and updating

NONE of what has been posted to this thread so far makes any sense to me. There might be some language barrier.

@B_ryr let’s go about it step by step. Please run the following commands in dom0 and post the output:

qvm-pci | grep USB

qvm-ls | grep usb

qvm-ls | grep TemplateVM

cat /etc/default/grub | grep hide_all_usb

1 Like

@HPOA909 those are some oddly specific statements on your part. Can you back any of this up?

Not knowing is OK. Not knowing and guessing / discussing (while making it clear as such) is also OK. However, not knowing and then posting statements as facts … that irritates me in a special way every time it happens. How does this help anyone?