Can someone help me please?


So I have an SSD with Windows 10 that I intend to keep as it is.

I also have an old HDD that I backed up with Google Drive and wiped, that I plan on installing Qubes onto. Here’s the video I followed to wipe my HDD (I did 1 pass): How to Wipe a Hard Drive - Permanently Delete All Data :: Windows 10 - YouTube

I wiped my HDD as a safety precaution. But I was told on Reddit that my HDD would need an operating system to download Qubes. According to File Explorer > This PC, My HDD has 0GB on it, so I’m sure the Windows 10 it used to use is gone.

So in my situation, how do I install Qubes with a new USB from start to finish? Should I remove my SSD before I begin?

Also, let’s say I have Qubes. Windows is only on my SSD, and Qubes is only on my HDD.
If I wanted Windows, would I unplug my HDD (Qubes) and install my SSD, so my PC automatically boots Windows?
If I wanted Qubes, would I unplug my SSD (Windows) and install my HDD, so my PC automatically boots Qubes?
In short, should I only have one storage device plugged in at a time - that being the one with the operating system I want to currently use, to maintain isolation between the operating systems?
I want Windows = SSD, HDD uninstalled
I want Qubes = HDD, SSD uninstalled

To avoid me being confused, please quote a specific question with an answer - I’ll learn better

Please explain from start to finish in steps like I’m 5 years old

An invite to DM 1-1 would be helpful

Thank you so much!

Some things are unclear to me, would you mind offering a bit more information …

  • What type of system (Desktop/Laptop) are you using? Make/Model #/code?

  • Are both the HDD & SSD internal? Or, are you planning to boot from them as external USB drives?

I know it’s been quite common for users to advise people who want to “try Qubes” to simply install Qubes to an external USB connected drive + boot from it but, with the way modern chipset integration has been going; this can be problematic for Qubes on some newer hardware.


Just last month I helped a user with an install who ran into this same issue. Another user on this forum tried to “help” by advising aforementioned “simple”/“safe” external install. Poor guy/gal was banging their head against a wall (error upon boot) trying to install Qubes externally yet, when installed directly to an internal drive, it was smooth a sailing/by the book install. Unfortunately, said user did NOT share the HCL as agreed. :face_with_spiral_eyes:

If I were in your shoes, I would install Qubes on your fast drive (SSD) internally and Win10 on your slow drive (HDD) externally. AFAIK, Win10 doesn’t mind booting from USB but, have no first-hand experience.

Maybe another user who does can chime in?

Hello! Thanks for the reply!

What type of system (Desktop/Laptop) are you using? Make/Model #/code?

My system is a custom-built PC, not a pre-built

Are both the HDD & SSD internal? Or, are you planning to boot from them as external USB drives?

My HDD is a 2TB Seagate Barracuda,
And my SSD is an M.2 Samsung 970 Pro, I believe

The fact that your windows is on an M.2 drive makes it a little more difficult to detach because they are smaller and connected to the motherboard with a tiny screw, etc. The best scenario is 2 - SATA connected drives where you can just switch the cables (or something). I agree with @cayce that an SSD is better, but the HDD should work fine for first use.

To install qubes:
Get an 8 or 16GB thumb drive,
Use rufus on Windows to write the qubes ISO to the drive.
Shutdown Windows
Swap the SSD for the HDD
Boot to the USB drive and install.

To switch OS, “just” shutdown the current, swap the cables/drives, and boot.

So what you’re saying is:
Step 1) Using my current Windows/SSD, use Rufus to write the Qubes ISO to my USB drive
Step 2) Enter my bios, make my USB drive my boot drive
Step 3) Before saving and exiting my bios, remove my SSD
Step 4) Boot my USB with my HDD installed and install Qubes from there

Whenever I want to rotate operating system, shut down the PC, remove the storage device with the operating system I’m not using, and install the storage device with the operating system I do want

Is that it?

Thank you for your time!

After installing, you’ll have to go into your bios again so it boots off the SSD. (I bring this up because you went to that level of detail in step 2.)

You’ve got it, but you want to shutdown and swap the drives before changing BIOS.
Also, any modern BIOS has a keystroke (F12) to open the boot menu. Just turn it on and hit F12 over and over until it comes up with that menu. That menu will allow you to select any attached drive to boot from, including USB. You can also get to setup from that menu.

Step 1) Using my current Windows/SSD, use Rufus to write the Qubes ISO to my USB drive (make sure you read the USB creation details in the documentation.)
Step 2) shutdown, detach your SSD and attach the HDD.
Step 3) Enter my bios, make my USB drive my boot drive (or just plug it in, turn it on, and use the F12 menu)
Step 4) Boot the USB with HDD installed and install Qubes from there

You’re a legend. Thank you!

Also, would you recommend this video for me to follow to put Qubes onto my USB?:

Never saw this video, but it seems like the basic process.

Is there another video you’d prefer me to follow?

Nope. that’ll work. Just doing it will help familiarization.

Thank you for everything!

1 Like

Hey man!

I did everything up to the beginning of Step 3.

Following the video, I did everything from downloading the iso to the USB, I then removed my SSD, and I forgot to enter the BIOS and set the USB as my boot drive. It then entered the Qubes installation thing where it asks you to set your language.

Then at the part where I select the USB drive to install Qubes onto, it just had my HDD despite in the video it was supposed to have the USB there too.

Then I noticed that I didn’t go into the BIOS to set the USB as the boot drive, so I reinstalled my SSD. I then realized that my USB isn’t showing in my files explorer, but according to my Windows 10 settings, the USB is connected.

Do you know hoe I can quickly fix that?

Thank you again

I believe when you create a USB boot drive with Qubes install, it will not mount in Windows.

It doesn’t matter. What matters is whether or not your BIOS can see that drive.
For instance, when you load the boot options in BIOS, you should see the USB drive. If you set your USB drive to the top of the boot list, it will only boot from USB if there is one that is bootable and attached.

The other consideration is that your BIOS will be set to either UEFI or legacy/CSM. Whatever that is set to for Windows, you want to leave it that way, and install qubes using the same mechanism. If you don’t make them the same, you would have to enter BIOS and switch it each time.

This is a typical F12 boot menu, where you can pick a specific device to boot from.

Hey man,

This USB is giving me some serious grief. Let me start from the beginning.

When beginning the steps we discussed above, I:
-Downloaded the iso on my SSD
-Went to Rufus, and installed the exe on my USB (mistake pointed out)
-Copied the video to put Qubes onto the USB
-Removed my SSD
-FORGOT to enter BIOS to make the USB the boot drive
-Began going through the language, etc and then realized that the USB didn’t show

I then:
-Realized that I forgot to enter the BIOS to make the USB
-Tried entering BIOS, and realized that my USB wasn’t a boot option
-Reinstalled my SSD
-Noticed that my USB was no longer visible when I went on File Explorer

I have no idea how to fix this. I went to Disk Manager, right-clicked on the USB, and it won’t even open properties (it clicks, but won’t open).
I then typed “diskpart” in the Windows search bar, ran it as administrator, and set the USB drive it’s own letter (U, for USB) (It was originally E).
I went to File explorer again, looked to see if my USB drive was there, and it was! I renamed it “64GB USB” for ease, but don’t remember what it was called there originally.

Here’s the problem - when I click on it, it says “You don’t currently have permission to access this folder”. The options are “Continue” (with the run as administrator shield icon) and “Cancel”, naturally. When I click on Continue, it says “You have been denied permission to access this folder”. Then in the smaller black font, it says “To gain access to this folder you will need to use the security tab” (Security tab is a blue highlighted link). I click on security tab, and it just comes up with the USB drive’s properties - and there is no security tab.

I restarted my PC, hoping at least the drive will remain visible, but it disappears again. It’s like a cycle.

Do you know how to make the USB stay where it is on File Explorer, and let me have permission to my own device again?

Thank you again

Are you using UEFI or Legacy mode?

Assuming you followed your video precisely (it matters).
In the video at 1:29 it shows selecting (in Rufus) the “partition scheme” of “MBR.”
This may be the problem.

Obviously, your screens may vary depending on the motherboard/BIS manufacturer, but in your BIOS, if you’re using UEFI only, the USB device with the MBR scheme may not show up as a bootable device, or it may show up as having both UEFI and legacy options. It’s hard to know.

BIOS selection (example)

Honestly, if the USB device has the ISO written to it correctly, it is irrelevant what Windows thinks about it. Windows (your SSD) will be out of the picture. completely.

All that matters is if your BIOS will let you boot to that USB device. You can try re-writing the ISO with GPT partition scheme, but it would be easier to confirm in your BIOS first which one is being used.

1 Like

You make an excellent point about the Windows SSD not needing to care. I thought it was an issue because I didn’t think Qubes would deal well with it, either…

Thank you!

Agreed. I would think the “absence” of the drive in Exploder is just due to missing file system drivers but, ought still be available from Disk Mangement. Or, does Win10/11 support file systems used by *nix out-of-the-box now?

Hi again,

I took these photos with my phone and emailed them to myself so I could show you the screen that I’m stuck on:

This time, I did the steps correctly:
-I installed both Qubes iso and Rufus to my SSD
-Used Rufus on my USB stick
-Shut down
-Removed my SSD
-Entered my BIOS and made my USB the ONLY boot option

Yet regardless, the USB still isn’t visible next to the HDD in the photos above, like the YouTube video I followed above

Do you know the fix to this?

Thank you