Can not change keyboard layout in fresh Qubes 4.1

Hey!

I made a fresh install of Qubes 4.1 and updated everything.
If I connect keyboard to a VM and want to change the keyboard layout, I get: “Please update the qube XYZ or its template to the newest version of Qubes tools”.

Is there an old version installed pr whats the point there?

Best regards
qun

Does nobody have an idea? It’s rather shi…y to use it at night with full light. :neutral_face:

What do you mean keyboard layout? Like “Querty → Dvorak” or "En-US → En-UK? I remember having issues like this long ago, I believe my solution was to change the keyboard setting in the “system settings” and reboot qubes - pro tip: set the keyboard to the correct type on install and you wont have this issue :stuck_out_tongue:

1 Like

Why don’t you update xyz template as you were intuitively suggested, shut down template, restart xyz qube and then get back with a feedback?

sometimes the solution is easier as we think :smiley: thank you! I just set the layout in the system settings and it woks.

i have english layout again! I suppose after restart.

I unchecked in the system settings “use system defaults”, so I have another layout there now, but it still has an english layout. It has no effect, even after restarting the VM.

It is updated and upgraded. And the suggestion to update “Qubes Tools” is strange, what are qubes tools on non WindowsVM?

Do you mean on Install of QubesOS? I set it to the layout I wanted.

are you changing the VM or the Template VM? VM’s (I believe) have their settings set to that of their parent Template VM when they start. As a general rule, VM’s everything aside from personal data reset every time you use them.

I think you should start over describing what and why you want to achieve, and then to describe the process until the error wit as much as possible details. Finding only in post #8 that you actually don’t use Windows VM will not help anyone.

I want to have german layout in the whole system if I connect the keyboard. I mean, I set in on installation process.

In the system settings of dom0 is german layout but not in the VMs. I make settings always in TemplateVMs ofcource. localectl status in dom0 shows german. But in the templateVM VC Keymap: n/a and X11 Layout: n/a. Even after reboot.

As it seems, its similar problem as here: Keyboard layout issue - #13 by qun

Even if I just want to set keyboard layout on any appVM, I get: “Please update the qube bank or its template to the newest version of Qubes tools”

What are “Qubes tools” and how can I get the newest version of them???
I thought Qubes tools are just the tools for the WindowsVM.

I’ve the same issues changing from English to German.
Any help welcome.