Brother Printer wont print anything

hi, been using qubes for a while and have set up multiple printer before mostly dymo. i upgraded to a brother ql1100 and i am trying to connect it but it won’t print anything.

I have a template including all my linux drivers for this specific printer and followed brother instructions off the site and i have a appvm based off this template and i connect the printer via system-config-printer and it shows its connected with a tick. I set my label template up and when i click print it shows the ‘job’ in the corner for a split second and then it dissapears and nothing happens.

I feel i am missing something really simple here and its frustrating the life out of me. I have set previous printers up no problem but this one is really causing me bother

Very grateful for any help

Have you tried maybe setting the “generic - color” driver for your printer? Printing usually works correctly on this driver.

Maybe you want to bookmark this thread too:

I have the same problem with fedora vm… However I have no problems with debian… But now I need to move everything to a debian vm before I can print anything… I also have the usb qube set up, everything looks and works perfect… I connect the printer to the fedora vm and it shows usb printer connected but nothing ever prints, just shows job pending forever. I have 2 brother printers with the same problem.

I think you need to do it in TemplateVM for that without connecting to the internet.

The following can be done via sudo or root:

lpadmin -p [printer name] -v [ipp or ipps]://[ip address of your printer]/ipp/print


  1. CUPS
  2. Print Settings

Thanks for the suggestion… This is set up as a usb printer. I think the “URI” might be the problem… Brother says " Check if the Device URI of your printer is “usb://Brother/(your printer’s model name)”

If the device URI is different from the example above, please go to “Modify Printer” of your printer to select proper device and driver."
But for some reason the browser is asking me for a user name and password and then telling me I am not authorized to make any changes… I think these changes might be made in the printer gui but I dont remember how to get to it… I will have to think about that…

ok i just somehow got one of the printers to work and the difference between the two is the “Connection: usb…” It seems they are being assigned the wrong connection during set up

system-config-printer is the command for the terminal window… Just changed the “Device URI:” Actually I had the option on the left hand side that seemed to match what brother said it should be now its fixed! YEEEHAWL!
Tried everything. USB printer. Installed as on the Brother website all three, installer, cupswrapper and lpr.
In Fedora template, in sys-usb and in an appvm. Doesn’t work. system-config-printer gives deprecated warnings and it seems Qubes only knows network-printers. Help! No printer = no working computer.

Today I was configuring a similar brother printer model at my place :slight_smile:

Here’s how I managed it:

  1. open an AppVM (based on fedora-37 or fedora-38) from which you would like to print something

  2. download the driver from Printer Drivers | Downloads | HL-2240 | United States | Brother

  3. go to the file manager and enter the folder where the file was downloaded to

  4. right-click in the empty field and select “Open in Terminal”

  5. enter the command:
    sudo chmod +x name_downloaded_package.rpm
    6 Enter the command:
    sudo rpm -ihv --nodeps name_downloaded_package.rpm

  6. connect the printer to the USB port

  7. open the Qube AppVm settings, and then go to the “Applications” tab

  8. move the “Settings” item to the right side and confirm

  9. then go to start_on_bar_tasks–> appvm → settings

  10. go to the “Printers” tab

  11. add the printer that will be automatically detected.

Good luck! :slight_smile:

1 Like

Did all that and tried again after reading your reply. Doesn’t work on Qubes 4.2. Printer can only be found under removable drives and media, and the default printer settings give error no printing service available. Thank you anyway.
Too much innovation in Fedora, too much security extremism in Qubes. I’ll have to return to Debian stable. No innovation there.