Bluetooth not working in Fedora 36 template

After I upgraded from the Fedora 34 template to Fedora 36, my Bluetooth device disappeared. I checked

journalctl -xb

in sys-usb, and this showed some Bluetooth errors. Googling those errors showed I needed a newer kernel. So I tried to use the kernel installed inside the VM, for both sys-usb and the target VM I wanted to use Bluetooth in.

However, now the situation is worse because, although sys-usb is able to detect Bluetooth, I am no longer able to attach any USB devices to other VMs at all.

I tried installing kernel-latest-qubes-vm in dom0 instead, and making both sys-usb and the AppVM use that kernel. This allowed the Bluetooth USB device to be visible, and allowed it to be connected to the AppVM. However, when I run systemsettings in the AppVM and try to pair my Bluetooth headphones, I get the error

“Internal error: could not prompt the user for which application to start”

It turns out that the application to start is bluedevil-wizard. After I restarted systemsettings and bluetooth and ran the wizard manually from the command line, I managed to connect my Bluetooth headphones.

How can I make bluedevil-wizard get run automatically?

I updated my Fedora template in-place - that might be why this doesn’t work.

Put the .desktop file in the following folder in Fedora linux to start the application during startup


If we want to start the application before my desktop starts (means to start during driver load) then put the shell script file in the below path

/etc/X11/xinit/xinitrc.d directory