Bluetooth headset not working

I had it working on an old Qubes 4.1 setup. Maybe something has changed since?

I installed blueman on my fedora-39 template which is used for sys-usb.

sudo dnf install blueman

I closed the template and restarted sys-usb and proceeded to open bluetooth manager. I am able to find and connect to my bluetooth headset however, i cannot get audio to play from any of my AppVM. Am i supposed to connect it to the VM via Qubes usb devices icon?

You need to set the sys-usb as audiovm for the qubes where you’re playing the audio.
In dom0:

qvm-prefs yourqubename audiovm sys-usb

Or you can change the audiovm globally for all qubes:

qubes-prefs default_audiovm sys-usb

You need to restart the qubes for them to start using new audiovm.


i dont want to risk adjusting global settings

i went with qvm-prefs yourqubename audiovm sys-usb

but its still not working. I am trying it in disp#### as i need it to work in disposables

Did you set:

qvm-prefs yourqubename audiovm sys-usb

For your disposable template?
You can’t change audiovm for a running qube.
It’s not supported yet:

1 Like

i tried the template as well

Should i have an audio VM? I only have sys-usb

Also, now audio does not work at all (mic, speakers, wired headset) on any of my Vms

Edit: audio output is working on my app vms which are not based on the same template as my disposable vms

You can use sys-usb is your audiovm. But maybe you’ll have to configure it for this.

It’s not working in any of your VMs or only on those based on the disposable template for which you’ve changed audiovm from dom0 to sys-usb?

Try to make bluetooth headset work for you using some test AppVM instead of disposables.

Maybe you need to properly configure sys-usb as audio qube or create separate sys-audio:

Or you can just attach your USB bluetooth controller to the qube where you want to use it.

To clear up any confusion:

Audio output and input are both dead on fedora-39-dvm, after doing this in dom0 terminal

qvm-prefs fedora-39-dvm audiovm sys-usb

Audio input (my built in microphone) is also dead on appvms that are not based on the fedora-39-dvm template. However audio output on is working

ive i come across sys-audio audio qube tutorial before but its far too complex for me.

I have always used sys-usb to manage audio. Typically use a wired headset and it worked perfectly but im waiting for a replacement.

You can return it to default (dom0) with this command:

qvm-prefs -D fedora-39-dvm audiovm

I’m not sure how changing fedora-39-dvm audiovm could affect it. Maybe try to reboot the system?

I don’t know how did you use sys-usb as audiovm without configuring it accordingly or directly attaching the bluetooth device from sys-usb to the AppVM where you wanted to use it.

audio output is working normally accross all VMs.

now its just that audio input is an issue. Cant seem to use my built-in mic. I’ve rebooted my system as well.

I’ve never successfully got bluetooth working on qubes. I normally use the ‘qubes devices’ icon in the top right toolbar to chose which VMs to pass my microphone to. I never had to configure anything for audio output

would restoring sys-usb from a backup fix this? or would i restore dom0?

Check the PulseAudio Volume Control in dom0.
Left mouse click on audio icon in tray → Audio mixer
In Recording tab check the devices connected to VMs.
Also check the Input devices tab and Configuration tab.

sys-usb shouldn’t be related to this issue.
Did you change anything in dom0 except for running qvm-prefs fedora-39-dvm audiovm sys-usb?

In dom0 all i did was
‘qvm-prefs fedora-39-dvm audiovm sys-usb’
‘qvm-prefs fedora-39-dvm audiovm’ [not sure what i was trying here lol]
‘qvm-prefs -D fedora-39-dvm audiovm’
‘qvm-prefs -D fedora-39 audiovm’ [in hopes of getting audo input working on non dvm AppVMs]

i just checked mic again today and it magically started working again… will update here again if it stops working. But qvm-prefs -D may have done the trick