Attempting to make a sys-audio VM: No sound and videos don't play in any VM

I followed the comment by @dom0 here: Debian-minimal template for sys-audio - #47 by dom0

At the end of it I was able to setup a sys-audio VM without any issues (I didn’t make it a disposable VM however, just a regular AppVM). Passthrough works although I had some difficulty in getting it to work at first.

However there’s no sound and videos don’t play on say Firefox in any VM. When I run pavucontrol from sys-audio I do see the VMs name in Playback, but for some reason no sound is going through.

I tried to add this line to /etc/modprobe.d/50-alsa.conf in dom0 as suggested in Setting up an audio VM - #24 by hamenarin but still no sound.

options snd_hda_intel enable=1 index=0 power_save=0

Would really appreciate it if someone could help me debug this issue.

What do you see in Output Devices?

When I wrote about needing to start and shutdown sys-audio for it to work, I always checked Output Devices in pavucontrol.

If it shows:

  • Built-in Audio Analog Stereo

then I know that sys-audio can play sound.

If it instead shows:

  • Dummy Output

then I know that sys-audio cannot play sound.

When Output Devices shows Dummy Output,

Input Devices shows:

  • No input devices available

and Configuration shows:

  • No cards available for configuration

So for me on my Librem 14, this issue was only fixed by rebooting until it worked.

Output Devices shows: Qubes vchan Output (plugged in).

I did reboot many times but it didn’t work.

Edit: Also the audio device is detected correctly in sys-audio:

user@sys-audio:~$ lspci -v | grep "Audio"
00:06.0 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)

Here’s the output of journalctl PrivateBin